Issue1064

classification
Title: 2.5 test_asynchat deadlocks
Type: crash Severity: normal
Components: Core Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, billiejoex, nriley, pjenvey, zyasoft
Priority: Keywords: patch

Created on 2008-06-24.21:30:34 by pjenvey, last changed 2009-03-12.06:52:59 by zyasoft.

Files
File name Uploaded Description Edit Remove
deadlock.txt nriley, 2008-12-03.22:08:33 stack trace of deadlock
pstack.txt nriley, 2008-12-05.18:42:28 pstack output
Messages
msg3305 (view) Author: Philip Jenvey (pjenvey) Date: 2008-06-24.21:30:34
on OS X 10.5 this test deadlocks most of the time. I've disabled it for 
now, but it looks like there is some kind of incompatibility with sockets 
and or select here
msg3636 (view) Author: Philip Jenvey (pjenvey) Date: 2008-10-02.19:54:06
I couldn't reproduce this on Linux 2.6.22/Java6

but it's easily reproducible on OS X 10.5/Java5 and FreeBSD/Java6
msg3637 (view) Author: Philip Jenvey (pjenvey) Date: 2008-10-02.20:21:58
couldn't reproduce on Windows/Java6 either
msg3668 (view) Author: Jim Baker (zyasoft) Date: 2008-10-11.23:46:55
Changed title to reflect it's current

test_numeric_terminator occasionally deadlocks on OS X 10.4 for me
msg3870 (view) Author: Nicholas Riley (nriley) Date: 2008-12-03.22:08:32
I could reproduce this on Windows XP with Java 6, and it was holding up
the buildbot so I disabled it there too (r5687).  Stack trace is attached.
msg3875 (view) Author: Nicholas Riley (nriley) Date: 2008-12-05.18:42:28
It deadlocks on Solaris too.  pstack output attached; it may be of 
slightly more help.
msg4133 (view) Author: Alan Kennedy (amak) Date: 2009-02-04.16:00:17
I've checked in a new version of asyncore at r6013.

I'll be doing some more testing with it in the coming days, particularly
in relation to this bug.

If anybody gets a chance, I'd be interested to see how the new version
runs on the different platforms, in relation to this bug.
msg4184 (view) Author: Alan Kennedy (amak) Date: 2009-03-07.16:35:00
Please can we re-enable test_asynchat to see if the problem still occurs
the most recent version?
msg4225 (view) Author: Jim Baker (zyasoft) Date: 2009-03-12.06:52:44
test_asynchat re-enabled on buildbots, no deadlocks observed. Closing.
History
Date User Action Args
2009-03-12 06:52:59zyasoftsetresolution: fixed
2009-03-12 06:52:46zyasoftsetstatus: open -> closed
messages: + msg4225
2009-03-07 17:01:09billiejoexsetnosy: + billiejoex
2009-03-07 16:35:00amaksetmessages: + msg4184
2009-02-04 16:00:18amaksetmessages: + msg4133
2008-12-05 18:42:29nrileysetfiles: + pstack.txt
messages: + msg3875
2008-12-03 22:08:34nrileysetfiles: + deadlock.txt
nosy: + nriley
messages: + msg3870
2008-10-11 23:46:55zyasoftsetnosy: + zyasoft
messages: + msg3668
title: 2.5 test_asynchat deadlocks on branches/asm -> 2.5 test_asynchat deadlocks
2008-10-02 20:21:58pjenveysetmessages: + msg3637
2008-10-02 19:54:06pjenveysetkeywords: + patch
messages: + msg3636
2008-06-24 21:30:34pjenveycreate