Title: Editline compatible method to inhibit completion on Tab
Type: Severity: normal
Components: None Versions:
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: nduboc, pjenvey
Priority: normal Keywords: patch

Created on 2007-10-22.11:25:49 by nduboc, last changed 2007-10-24.23:53:18 by pjenvey.

File name Uploaded Description Edit Remove
inhibit-completion.patch nduboc, 2007-10-22.11:25:49
msg2944 (view) Author: Nicolas Duboc (nduboc) Date: 2007-10-22.11:25:49
In Jython 2.2.1, uses Readline.parseAndBind to inhibit file names completion on Tab in the interactive interpreter. This method only works for the pure Readline implementation.

The joined patch uses another method to inhibit completion that works with GnuReadline and Editline implementation.

The Debian package of Jython relies on Editline for license reasons. I'm about to upload version 2.2.1 into Debian and it will include this fix.

Please consider this patch for the next Jython version.

msg2945 (view) Author: Philip Jenvey (pjenvey) Date: 2007-10-24.23:53:18
This is a dupe of #795831 (which was actually opened ages ago by the old debian maintainer =] )

I just updated it with another comment
Date User Action Args
2007-10-22 11:25:49nduboccreate