Author jeff.allen
Recipients amak, emcdowell, fwierzbicki, jeff.allen, pjenvey, vitaly
Date 2013-05-09.21:11:58
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
The readline problem that affects interactive sessions (including scripts specified with the -c option from the shell prompt) is not the same one that Vitaly originally reports affecting subprocesses on Mac OS/X.

I have tried Vitaly's script on Windows 7. I have had to modify it because Windows does not support fcntl (or os.O_NONBLOCK). I can therefore only run the cat-block and cat-fdblock tests. Also, the close_fds option to Popen is not supported, and the jython command (being a batch file) can only be found if I use the Popen Shell=True option.

These do not hang for me on 2.5.2, 2.5.4rc1 or 2.7b1+; they hang on 2.5.3.

Although they do not hang, they fail because the returned line is terminated by \r while the sent line is terminated by \n. With that finessed they work. I've posted my variant of the test.

So it looks like this issue is fixed for Windows in 2.5.4rc1 (as long as we are talking about the right bug). I'm not closing as I don't know if the original problem (on Mac) persists. I'm de-assigning myself as I don't have a Mac.

Vitaly: have you tried this with 2.5.4rc1 on Mac?
Date User Action Args
2013-05-09 21:12:00jeff.allensetmessageid: <>
2013-05-09 21:12:00jeff.allensetrecipients: + jeff.allen, fwierzbicki, amak, pjenvey, vitaly, emcdowell
2013-05-09 21:12:00jeff.allenlinkissue1972 messages
2013-05-09 21:11:59jeff.allencreate