Issue1011

classification
Title: ant task to create launcher script
Type: rfe Severity: normal
Components: Core Versions: 2.5alpha1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: nriley, pjenvey
Priority: Keywords:

Created on 2008-03-19.17:31:45 by nriley, last changed 2008-11-23.21:43:46 by nriley.

Messages
msg3096 (view) Author: Nicholas Riley (nriley) Date: 2008-03-19.17:31:45
Create an ant task to build a launcher script (e.g., java
-Dpython.executable <foo> -jar dist/jython.jar xxx) for Unix and Windows
platforms.  The script can be output in the dist directory along with
the built jar file.

This could also be used to run the regression tests via ant regrtest
(perhaps creating the script in a temporary directory), so those tests
which fail because sys.executable is not set will work.
msg3235 (view) Author: Philip Jenvey (pjenvey) Date: 2008-06-07.22:45:52
This ticket is almost done -- Frank stole JRuby's launcher, now we have 
one living under dist/bin/jython. Nick also added some things to it

What's left to do before closing this out is create a Windows version
msg3325 (view) Author: Nicholas Riley (nriley) Date: 2008-07-15.17:11:56
Before this can replace the 'jython' script generated by the installer we 
also need to prefer "jython-complete.jar" as "jython.jar" does not exist 
in the built version, and pass through the JAVA_HOME selected in the 
installer.
msg3328 (view) Author: Nicholas Riley (nriley) Date: 2008-07-15.22:34:48
An initial Windows launcher script (has fewer features than the Unix
one) is in r4950.
msg3840 (view) Author: Nicholas Riley (nriley) Date: 2008-11-23.21:43:46
Good enough for now.
History
Date User Action Args
2008-11-23 21:43:46nrileysetstatus: open -> closed
resolution: fixed
messages: + msg3840
2008-07-15 22:34:48nrileysetmessages: + msg3328
2008-07-15 17:12:04nrileysetmessages: + msg3325
2008-06-07 22:45:52pjenveysetnosy: + pjenvey
messages: + msg3235
2008-03-19 17:31:45nrileycreate