Issue1025

classification
Title: imp.find_module can't find builtin modules
Type: Severity: normal
Components: Core Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: fwierzbicki, pjenvey
Priority: Keywords:

Created on 2008-04-18.20:43:32 by pjenvey, last changed 2008-12-16.03:16:58 by pjenvey.

Messages
msg3161 (view) Author: Philip Jenvey (pjenvey) Date: 2008-04-18.20:43:31
Python 2.5.1 (r251:54863, Aug 19 2007, 21:02:30) 
[GCC 4.0.1 (Apple Computer, Inc. build 5367)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import imp
>>> imp.find_module('sys')
(None, 'sys', ('', '', 6))

Jython 2.3a0 on java1.5.0_13
Type "copyright", "credits" or "license" for more information.
>>> import imp
>>> imp.find_module('sys')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named sys
msg3930 (view) Author: Philip Jenvey (pjenvey) Date: 2008-12-16.03:16:57
this was fixed in r5735 (#1161 was a dupe of it)
History
Date User Action Args
2008-12-16 03:16:58pjenveysetstatus: open -> closed
resolution: fixed
messages: + msg3930
2008-04-18 23:15:02fwierzbickisetnosy: + fwierzbicki
2008-04-18 20:43:32pjenveycreate