Issue1065

classification
Title: ClassCastException in cPickle
Type: Severity: normal
Components: Core Versions:
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: fwierzbicki, patrick, zyasoft
Priority: Keywords: patch

Created on 2008-06-24.22:11:11 by patrick, last changed 2009-03-08.07:58:53 by zyasoft.

Files
File name Uploaded Description Edit Remove
classcast.txt patrick, 2008-06-24.22:11:11 Bug description
cPickle_1065.patch zyasoft, 2009-03-08.07:58:53
Messages
msg3729 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2008-11-01.13:53:32
Any chance that we could get a code sample that reproduces this problem?
msg4201 (view) Author: Jim Baker (zyasoft) Date: 2009-03-08.07:58:53
I was able to create a test out of patrick's submitted classcast.txt
file, however it appears that cPickle no longer has this problem -
CPython and Jython produce the same (correct) result.
History
Date User Action Args
2009-03-08 07:58:53zyasoftsetstatus: open -> closed
files: + cPickle_1065.patch
nosy: + zyasoft
messages: + msg4201
keywords: + patch
resolution: works for me
2008-11-01 13:53:40fwierzbickisetcomponents: + Core
2008-11-01 13:53:32fwierzbickisetnosy: + fwierzbicki
messages: + msg3729
2008-06-24 22:11:11patrickcreate