Issue1071

classification
Title: strftime uses 2-letter %a and system locale
Type: Severity: normal
Components: Library Versions: 2.5alpha1
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: ReneLeonhardt, leosoto, nriley
Priority: Keywords:

Created on 2008-07-16.06:31:40 by ReneLeonhardt, last changed 2008-09-15.03:39:46 by leosoto.

Files
File name Uploaded Description Edit Remove
test-strftime.py ReneLeonhardt, 2008-07-16.06:31:39 Test strftime(%a)
Messages
msg3333 (view) Author: (ReneLeonhardt) Date: 2008-07-16.06:31:38
It seems that Jython respects the system locale for time.strftime(),
while Python uses the English locale values for %a and %b (in my case).
And it looks wrong that Jython uses the 2-letter %a while Python uses
the 3-letter format.

On Wednesday it prints "Wed" in Python and "Mi" for Jython (german
system locale).
msg3483 (view) Author: (ReneLeonhardt) Date: 2008-09-07.17:40:45
The problem still exists in 2.5a2.
msg3566 (view) Author: Leonardo Soto (leosoto) Date: 2008-09-14.00:59:08
Interestingly, http://docs.python.org/lib/module-time.html says that
strftime should use the locale names.
msg3568 (view) Author: Nicholas Riley (nriley) Date: 2008-09-14.01:13:01
At least on Windows, CPython does return localized month/day names, so 
this is not a bug.  See, for example:

http://bugs.python.org/issue836035
msg3599 (view) Author: Leonardo Soto (leosoto) Date: 2008-09-15.03:39:46
OK, so I'm closing this as invalid. If new arguments are made, we can
always open it again.
History
Date User Action Args
2008-09-15 03:39:46leosotosetstatus: open -> closed
resolution: invalid
messages: + msg3599
2008-09-14 01:13:01nrileysetnosy: + nriley
messages: + msg3568
2008-09-14 00:59:08leosotosetnosy: + leosoto
messages: + msg3566
2008-09-07 17:40:45ReneLeonhardtsetmessages: + msg3483
2008-07-16 06:31:40ReneLeonhardtcreate