Issue1089

classification
Title: cStringIO doesn't return unicodes when it should
Type: Severity: normal
Components: Core Versions:
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: leosoto, zyasoft
Priority: Keywords:

Created on 2008-07-30.16:55:15 by leosoto, last changed 2008-09-13.17:05:57 by leosoto.

Messages
msg3370 (view) Author: Leonardo Soto (leosoto) Date: 2008-07-30.16:55:15
This is different from the behaviour of plain StringIO:

>>> import cStringIO, StringIO
>>> StringIO.StringIO(u'unicode text').read()
u'unicode text'
>>> cStringIO.StringIO(u'unicode text').read()
'unicode text'
msg3506 (view) Author: Jim Baker (zyasoft) Date: 2008-09-13.16:33:51
This is not a bug, it's a "feature". CPython has the same behavior, so
we don't want to deviate from that. (Hence, the need for 3.0.)

Need a test case to ensure that we don't break this "feature".
msg3509 (view) Author: Leonardo Soto (leosoto) Date: 2008-09-13.17:05:57
OK, test added on r5323

And, BTW, looks like for future releases this issue could be solved on
CPython:
<http://mail.python.org/pipermail/python-list/2007-June/445650.html>
History
Date User Action Args
2008-09-13 17:05:57leosotosetstatus: pending -> closed
messages: + msg3509
2008-09-13 16:33:51zyasoftsetstatus: open -> pending
resolution: invalid
messages: + msg3506
nosy: + zyasoft
2008-07-30 16:55:15leosotocreate