Issue1101

classification
Title: Jython 2.2.1 on z/os hangs
Type: behaviour Severity: normal
Components: Jythonc compiler Versions: 2.2.1rc1
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: amak, dysonbags, fwierzbicki
Priority: low Keywords:

Created on 2008-08-08.14:55:23 by dysonbags, last changed 2012-04-11.17:32:56 by fwierzbicki.

Messages
msg3409 (view) Author: Graham (dysonbags) Date: 2008-08-08.14:59:40
I have installed jython 2.2.1 on Windows XP and it works fine. I've
tried to install on Z/OS 1.8 and it appears to install correctly
(message Congratulations! You successfully installed Jython 2.2.1 to
directory /u/Y057AHE/jython/install. received. However when I try to run
the graph example, it just hangs. I see 

MVS2 # jythonc --package pygraph Graph.py
import: 'exceptions' as org.python.core.exceptions in builtin modules
Jython 2.2.1 on java1.4.2
import: 'site' as /u/Y057AHE/jython/install/Lib/site.py
import: 'sys' as sys in builtin modules
import: 'os' as org.python.modules.os in builtin modules
import: 'javaos' as /u/Y057AHE/jython/install/Lib/javaos.py
import: 'java' as java package
import: 'File' as java class
import: 'System' as java class
import: 'javapath' as /u/Y057AHE/jython/install/Lib/javapath.py
import: 'IOException' as java class
import: 'UserDict' as /u/Y057AHE/jython/install/Lib/UserDict.py
import: 'time' as org.python.modules.time.Time in builtin modules
import: 'stat' as /u/Y057AHE/jython/install/Lib/stat.py
import: 'string' as /u/Y057AHE/jython/install/Lib/string.py
Type "copyright", "credits" or "license" for more information.


then nothing else. Only thing I can do is cancel my session. 

Is there a known problem on Z/OS or have I done something wrong?
msg3514 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2008-09-13.17:47:34
I see that you are trying to use jythonc -- have you tried using just
jython on z/os?  I'm afraid I don't know if we have any z/os machines to
test with.
msg6883 (view) Author: Alan Kennedy (amak) Date: 2012-03-19.21:19:53
Do we plan to address this issue? Will there be a maintenance release of jython 2.2?

Should we request the user to try jython 2.5 instead?

This issue seems to have made far more progress with jython on z/OS

http://bugs.jython.org/issue550200
msg6896 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-03-19.22:39:58
dysonbags: have you tried this with Jython 2.5.2? There isn't much chance for it to get fixed in 2.2.
msg7046 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-04-11.17:32:56
I think since there is no reply for four years from the poster that we can safely close this one.
History
Date User Action Args
2012-04-11 17:32:56fwierzbickisetstatus: open -> closed
resolution: out of date
messages: + msg7046
2012-03-19 22:39:58fwierzbickisetmessages: + msg6896
2012-03-19 21:19:53amaksetnosy: + amak
messages: + msg6883
2009-03-12 07:20:21zyasoftsetpriority: low
2008-11-04 15:42:26fwierzbickisetcomponents: + Jythonc compiler, - Core
2008-09-13 17:47:34fwierzbickisetnosy: + fwierzbicki
messages: + msg3514
2008-08-08 14:59:40dysonbagssetmessages: + msg3409
2008-08-08 14:55:23dysonbagscreate