Issue1149

classification
Title: Windows path handling problem: Files\Java\jdk] was unexpected at this time
Type: behaviour Severity: major
Components: None Versions: 2.5alpha3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: otmarhumbel Nosy List: fwierzbicki, jaraco, otmarhumbel
Priority: Keywords:

Created on 2008-10-11.17:08:39 by jaraco, last changed 2008-10-13.17:10:04 by fwierzbicki.

Messages
msg3659 (view) Author: Jason R. Coombs (jaraco) Date: 2008-10-11.17:08:38
With jython 2.5a3 on Windows Vista 32-bit with Java installed in
c:\Program Files\Java\jdk and Java installed to c:\Program
Files\Java\jython, and both paths set in the environment, I get the
following error:

C:\Users\jaraco>"c:\Program Files\Java\jython\bin\jython.bat" -V
Files\Java\jdk] was unexpected at this time.

This occurs during the first few lines of jython.bat (where it's
detecting _JAVA_CMD).

It appears as if the syntax of the if statement is incorrect for names
with spaces in them.  Consider

set _JAVA_CMD=java
if not "%JAVA_HOME%" == "" (
   set _JAVA_CMD=%JAVA_HOME%\bin\java
)
msg3669 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2008-10-12.18:38:59
Hey Oti, I assigned this one to you since I think you and Nicholas are the 
only clueful .bat users around here...
msg3673 (view) Author: Oti Humbel (otmarhumbel) Date: 2008-10-13.16:40:02
I believe this is a duplicate of issue 1125 (see
http://bugs.jython.org/msg3672)
msg3674 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2008-10-13.17:10:03
Oti, indeed it is - closing as a dup of #1125
History
Date User Action Args
2008-10-13 17:10:04fwierzbickisetstatus: open -> closed
resolution: duplicate
messages: + msg3674
2008-10-13 16:40:02otmarhumbelsetmessages: + msg3673
2008-10-12 18:38:59fwierzbickisetassignee: otmarhumbel
messages: + msg3669
severity: normal -> major
nosy: + fwierzbicki, otmarhumbel
2008-10-11 17:08:39jaracocreate