Issue1172

classification
Title: install failed
Type: crash Severity: critical
Components: Installer Versions: 2.5b0
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: Tominator2, daveyost, otmarhumbel, zyasoft
Priority: Keywords:

Created on 2008-11-17.21:46:40 by daveyost, last changed 2009-03-08.07:15:54 by zyasoft.

Messages
msg3783 (view) Author: Dave Yost (daveyost) Date: 2008-11-17.21:46:39
Version is 2.5b0, but your Versions list does not include that version.

Tried to install jython 2.5b0 in Eclipse PyDev on Mac.

I get this message:
Check your error log for more details.

More info can also be found at the bug report: 
http://sourceforge.net/tracker/index.php?
func=detail&aid=1523582&group_id=85796&atid=577329
No output was in the standard output when trying to create the 
interpreter info.
The error output contains:>>*sys-package-mgr*: can't create package 
cache dir, '/Volumes/Other/Local/Library/jython/jython/jython-
complete.jar/cachedir/packages'
Traceback (most recent call last):
  (no code object) at line 0
ImportError: No module named os
<<
msg3785 (view) Author: Oti Humbel (otmarhumbel) Date: 2008-11-18.08:38:06
Dave,

could you please give us a list of the steps to reproduce the problem?
'install in Eclipse PyDev' is a bit general, and the tracker item you
provided does not really help.
msg3865 (view) Author: Thomas Bitterman (Tominator2) Date: 2008-12-02.17:09:55
prereqs:
- install eclipse 3.4.1
- install pydev plug-in 1.3.24
- create a java project
- add the "pydev project config" to the project
- it might be nice to have some source files in the project, including
some python files

to reproduce the bug:
- go to Window -> Preferences -> Interpreter-Jython
- click the "New" button next to the "Jython interpreters" box
- navigate to the jython-complete.jar file, choose it and select ok
- yay! error
- note the not really helpful tracker item in the error window
msg3866 (view) Author: Thomas Bitterman (Tominator2) Date: 2008-12-02.17:40:42
Oddly enough, the error goes away when jython-complete.jar is renamed to
jython.jar.  Looks like a PyDev error.
msg4197 (view) Author: Jim Baker (zyasoft) Date: 2009-03-08.07:15:53
Submitter indicates this is a bug in PyDev, so closing. Please comment
if you see this bug recur in the latest beta.
History
Date User Action Args
2009-03-08 07:15:54zyasoftsetstatus: open -> closed
nosy: + zyasoft
resolution: invalid
messages: + msg4197
2008-12-02 17:40:43Tominator2setmessages: + msg3866
2008-12-02 17:09:56Tominator2setnosy: + Tominator2
messages: + msg3865
versions: + 2.5b0, - 2.5alpha3
2008-11-18 08:38:07otmarhumbelsetnosy: + otmarhumbel
messages: + msg3785
2008-11-17 21:46:40daveyostcreate