Issue1213

classification
Title: PythonInterpreter.initialize() throws NullPointerException without explanation
Type: behaviour Severity: normal
Components: Core Versions: 2.5.1
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: doublep, otmarhumbel
Priority: Keywords:

Created on 2008-12-29.10:44:30 by doublep, last changed 2008-12-29.14:37:35 by otmarhumbel.

Messages
msg3977 (view) Author: (doublep) Date: 2008-12-29.10:44:30
I'm trying to use PythonInterpreter.initialize() only to get
NullPointerException thrown in my face without explanation.  Moreover,
stacktrace lines don't match source code, so I cannot even understand
what's wrong from the sources (standalone installation here, dunno if
that matters).

Please rewrite initialization so that it either never throws (assuming
default values instead) or throws explaining what it wants.  E.g. throw
new NullPointerException ("foo.bar is not set, you suck");

Current behavior is just frustrating.
msg3978 (view) Author: Oti Humbel (otmarhumbel) Date: 2008-12-29.10:54:03
I assume you are embedding jython.

Could you please describe exactly how we could reproduce this, e.g.
 - how you start java (including -cp / -classpath)
 - how you call the initialize method (it has 3 parameters)

Thanks!
msg3979 (view) Author: (doublep) Date: 2008-12-29.11:46:16
Sorry, disregard this.  It seems I get f*cked up by Java class paths
once again.  I sure have 2.5b0 in classpath (just verified by running
the JAR with 'java -jar'), but 2.1 creeps out of something else I use
and I have no idea where from :(  I just hate it, especially because in
Java I cannot do 'print module' to find out where it comes from, as in
Python.

Please close as invalid.
msg3982 (view) Author: Oti Humbel (otmarhumbel) Date: 2008-12-29.14:37:35
closing, as requested
History
Date User Action Args
2008-12-29 14:37:35otmarhumbelsetstatus: open -> closed
resolution: invalid
messages: + msg3982
2008-12-29 11:46:17doublepsetmessages: + msg3979
2008-12-29 10:54:03otmarhumbelsetnosy: + otmarhumbel
messages: + msg3978
2008-12-29 10:44:30doublepcreate