Issue1224

classification
Title: IPv6 support is broken
Type: Severity: urgent
Components: Library Versions: 2.5.1, 2.5b0
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, billiejoex, pjenvey
Priority: normal Keywords: ipv6

Created on 2009-01-10.15:27:40 by billiejoex, last changed 2009-05-29.01:50:39 by pjenvey.

Messages
msg4018 (view) Author: Giampaolo Rodola' (billiejoex) Date: 2009-01-10.15:27:39
C:\jython2.5b0\bin>jython.bat
Jython 2.5b0 (trunk:5540, Oct 31 2008, 13:55:41)
[Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on java1.6.0_11
Type "help", "copyright", "credits" or "license" for more information.
>>> import socket
>>> socket.has_ipv6
1
>>> s = socket.socket(socket.AF_INET6, socket.SOCK_STREAM)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\jython2.5b0\Lib\socket.py", line 1036, in __init__
    _sock = _realsocket(family, type, proto)
  File "C:\jython2.5b0\Lib\socket.py", line 519, in _realsocket
    assert family == AF_INET
AssertionError
>>>
msg4019 (view) Author: Giampaolo Rodola' (billiejoex) Date: 2009-01-10.15:28:05
Moreover, socket.has_ipv6 should contain a boolean, not and in.
msg4535 (view) Author: Alan Kennedy (amak) Date: 2009-04-18.13:10:19
I have checked in a new value for the has_ipv6 flag, namely False.

We don't support IPV6 right now, but will in the future, when a clear
testing strategy is available.

This may happen after the 2.5 release.
msg4753 (view) Author: Philip Jenvey (pjenvey) Date: 2009-05-29.01:50:39
This is fixed since the flag now reflects reality, but I'll mark it as a 
dupe of #1210
History
Date User Action Args
2009-05-29 01:50:39pjenveysetstatus: open -> closed
resolution: duplicate
messages: + msg4753
nosy: + pjenvey
2009-04-18 13:10:19amaksetassignee: amak
messages: + msg4535
nosy: + amak
2009-03-14 14:31:38fwierzbickisetpriority: normal
2009-01-28 16:44:35amaksetkeywords: + ipv6
2009-01-10 15:36:19billiejoexsetseverity: normal -> urgent
components: + Library
versions: + 2.5b0
2009-01-10 15:28:05billiejoexsetmessages: + msg4019
2009-01-10 15:27:40billiejoexcreate