Issue1231

classification
Title: 2.5b1 breaks XML DocumentBuilderFactory (in particular, Weblogic 10.3)
Type: Severity: major
Components: Versions: 2.5b1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: cgroves, dingo, doublep, fwierzbicki
Priority: Keywords:

Created on 2009-01-12.12:20:17 by doublep, last changed 2009-01-24.20:24:44 by cgroves.

Files
File name Uploaded Description Edit Remove
test.java doublep, 2009-01-14.13:07:58 test program
Messages
msg4032 (view) Author: (doublep) Date: 2009-01-12.12:20:16
After upgrading from 2.5b0 to 2.5b1 (no other changes), JSP pages
compilation broke down completely.  I get this for every page:

javax.xml.parsers.FactoryConfigurationError: Provider
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found
	at
javax.xml.parsers.DocumentBuilderFactory.newInstance(DocumentBuilderFactory.java:129)
	at
weblogic.jsp.internal.jsp.JspTagLibraryFeature.parseTldFromWebXML(JspTagLibraryFeature.java:879)
        ...

Note that 2.5b0 worked fine.
msg4044 (view) Author: (doublep) Date: 2009-01-14.13:07:57
Here is a trivial test program.  If it matters, Java 1.6.0_05 here.

$ javac test.java && java -cp ~/jython2.5b0-standalone/jython.jar:. test
com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl@15f5897
$ javac test.java && java -cp ~/jython2.5b1-standalone/jython.jar:. test
Exception in thread "main" javax.xml.parsers.FactoryConfigurationError:
Provider org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found
        at
javax.xml.parsers.DocumentBuilderFactory.newInstance(DocumentBuilderFactory.java:129)
        at test.main(test.java:7)

With 2.5b0 it works fine, 2.5b1 it breaks.
msg4046 (view) Author: Charlie Groves (cgroves) Date: 2009-01-14.16:59:27
This is caused by our inclusion of a renamed xerces in Jython that
includes its META-INF/services/javax.xml.parsers.DocumentBuilderFactory
without renaming the class specified in there.  To make this work, we'll
either need to strip out all the META-INF/services classes when
including xerces, or we'll need to change the names of the classes in them.
msg4047 (view) Author: (doublep) Date: 2009-01-15.08:11:00
It seems that Java 6 ships with Xerces already, though probably an older
version.  Are you sure you need another one (though maybe for older Java
you do)?  In that case I suggest you do what Sun does with stock
version: rename org.apache.xerces.* to org.python.org.apache.xerces.* or
something like that.
msg4048 (view) Author: (doublep) Date: 2009-01-15.08:13:29
Ah, disregard last comment, you already do.  So it seems all that is
needed is to fix
'META-INF/services/javax.xml.parsers.DocumentBuilderFactory' and
probably similar files in 'META-INF', right?
msg4071 (view) Author: Charlie Groves (cgroves) Date: 2009-01-24.20:24:44
We no longer include the service files in our jar on trunk.  Thanks for
the report!
History
Date User Action Args
2009-01-24 20:24:44cgrovessetstatus: open -> closed
resolution: fixed
messages: + msg4071
2009-01-22 20:47:03dingosetnosy: + dingo
2009-01-18 01:03:41fwierzbickisetnosy: + fwierzbicki
2009-01-15 08:13:29doublepsetmessages: + msg4048
2009-01-15 08:11:00doublepsetmessages: + msg4047
2009-01-14 16:59:27cgrovessetnosy: + cgroves
messages: + msg4046
2009-01-14 13:08:53doublepsettitle: 2.5b1 breaks Weblogic 10.3 -> 2.5b1 breaks XML DocumentBuilderFactory (in particular, Weblogic 10.3)
2009-01-14 13:07:58doublepsetfiles: + test.java
messages: + msg4044
2009-01-12 12:20:17doublepcreate