Issue1236

classification
Title: Django 1.0.2 jython setup.py install fails in 2.5b1 (ok in 2.5b0)
Type: behaviour Severity: normal
Components: Core Versions: 2.5b1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: crankycoder, mlevalle, pjenvey
Priority: Keywords:

Created on 2009-01-13.11:08:13 by mlevalle, last changed 2009-02-04.20:47:34 by pjenvey.

Messages
msg4040 (view) Author: Michael A. LeValle (mlevalle) Date: 2009-01-13.11:08:11
I am able to install Django 1.0.2 successfully using Jython2.5b0 using:
jython setup.py install. This fails in Jython2.5b1 with the following
output (I get the same behavior on Windows and Linux):

$jython setup.py install
running install
running build
running build_py
running build_scripts
running install_lib
copying build/lib/django/db/models/manager.py ->
/usr/local/share/jython/current/Lib/site-packages/django/db/models
Traceback (most recent call last):
  File "setup.py", line 73, in <module>
    setup(
  File "/usr/local/share/jython/current/Lib/distutils/core.py", line
151, in setup
    dist.run_commands()
  File "/usr/local/share/jython/current/Lib/distutils/core.py", line
151, in setup
    dist.run_commands()
  File "/usr/local/share/jython/current/Lib/distutils/dist.py", line
974, in run_commands
    self.run_command(cmd)
  File "/usr/local/share/jython/current/Lib/distutils/dist.py", line
994, in run_command
    cmd_obj.run()
  File
"/usr/local/share/jython/current/Lib/distutils/command/install.py", line
517, in run
    self.run_command(cmd_name)
  File "/usr/local/share/jython/current/Lib/distutils/cmd.py", line 333,
in run_command
    self.distribution.run_command(command)
  File "/usr/local/share/jython/current/Lib/distutils/dist.py", line
994, in run_command
    cmd_obj.run()
  File
"/usr/local/share/jython/current/Lib/distutils/command/install_lib.py",
line 95, in run
    outfiles = self.install()
  File
"/usr/local/share/jython/current/Lib/distutils/command/install_lib.py",
line 116, in install
    outfiles = self.copy_tree(self.build_dir, self.install_dir)
  File "/usr/local/share/jython/current/Lib/distutils/cmd.py", line 385,
in copy_tree
    return dir_util.copy_tree(
  File "/usr/local/share/jython/current/Lib/distutils/dir_util.py", line
169, in copy_tree
    outputs.extend(
  File "/usr/local/share/jython/current/Lib/distutils/dir_util.py", line
169, in copy_tree
    outputs.extend(
  File "/usr/local/share/jython/current/Lib/distutils/dir_util.py", line
169, in copy_tree
    outputs.extend(
  File "/usr/local/share/jython/current/Lib/distutils/dir_util.py", line
174, in copy_tree
    copy_file(src_name, dst_name, preserve_mode,
  File "/usr/local/share/jython/current/Lib/distutils/file_util.py",
line 172, in copy_file
    os.utime(dst, (st[ST_ATIME], st[ST_MTIME]))
  File "/usr/local/share/jython/current/Lib/os.py", line 557, in utime
    atimeval = _to_timeval(times[0])
  File "/usr/local/share/jython/current/Lib/os.py", line 574, in _to_timeval
    from org.jruby.ext.posix.util import Platform
ImportError: No module named jruby
msg4050 (view) Author: Victor Ng (crankycoder) Date: 2009-01-16.15:06:00
I can reproduce that error over here as well.  I don't seem to have an
old jython.jar in my classpath.

---


Jython 2.5b1 (trunk:5903:5905, Jan 9 2009, 16:01:29)
[Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on java1.6.0_07
Type "help", "copyright", "credits" or "license" for more information.
>>> import os
>>> for p in os.getenv("CLASSPATH").split(";"):
...   print p
...
.
.\ASEP\3pclass.zip
.\ASEP\Monclass.zip
c:\dev\jtds\jtds-1.2.2.jar
c:\dev\cpprepo\jython\db\lib\commons-dbcp-1.2.2.jar
c:\dev\cpprepo\jython\db\lib\commons-pool-1.4.jar
>>> print os.getenv("PYTHONPATH")
None
>>> print os.getenv("JYTHONPATH")
None
>>> from os import _to_timeval
>>> _to_timeval(10)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\jython2.5b1\Lib\os.py", line 574, in _to_timeval
    from org.jruby.ext.posix.util import Platform
ImportError: No module named jruby
>>>
msg4141 (view) Author: Philip Jenvey (pjenvey) Date: 2009-02-04.20:47:34
dupe of #1229, this is already fixed in trunk
History
Date User Action Args
2009-02-04 20:47:34pjenveysetstatus: open -> closed
resolution: duplicate
messages: + msg4141
nosy: + pjenvey
2009-01-16 15:06:01crankycodersetnosy: + crankycoder
messages: + msg4050
2009-01-13 11:08:13mlevallecreate