Issue1256

classification
Title: sitecustomize import gives KeyError, isn't caught by ImportError guard
Type: Severity: critical
Components: Core Versions: 2.5.1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: fwierzbicki, jfeinberg, pjenvey, zyasoft
Priority: low Keywords:

Created on 2009-01-30.20:01:03 by jfeinberg, last changed 2009-05-31.21:58:04 by pjenvey.

Messages
msg4114 (view) Author: Jonathan Feinberg (jfeinberg) Date: 2009-01-30.20:01:18
error importing site
Traceback (most recent call last):
  File "C:\jython2.5b1\Lib\site.py", line 418, in <module>
    main()
  File "C:\jython2.5b1\Lib\site.py", line 411, in main
    execsitecustomize()
  File "C:\jython2.5b1\Lib\site.py", line 392, in execsitecustomize
    import sitecustomize
  File "C:\jython2.5b1\Lib\site.py", line 392, in execsitecustomize
    import sitecustomize
KeyError: 'sitecustomize'
msg4230 (view) Author: Jim Baker (zyasoft) Date: 2009-03-12.07:38:44
This logic is the same as CPython's, which doesn't explicitly catch
KeyError. Can you please give a more detailed scenario when this
happens, ideally against trunk or 2.5b3?
msg4298 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-03-14.15:01:00
since there is no further input on this bug, I've set the priority to
low.  If we don't hear something in a month or so, we should just close it.
msg4299 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-03-14.15:04:19
oops, misread the date on zyasoft's request for info (was a day or two
old, looked much older to me) -- sorry!  Scratch the note about closing
in a month.
msg4777 (view) Author: Philip Jenvey (pjenvey) Date: 2009-05-31.21:58:03
Been almost 3 months since the last inquiry, closing out. Please go ahead 
and reopen this with the further information if you can reproduce it on 
the latest release
History
Date User Action Args
2009-05-31 21:58:04pjenveysetstatus: open -> closed
resolution: fixed
messages: + msg4777
nosy: + pjenvey
2009-03-14 15:04:19fwierzbickisetmessages: + msg4299
2009-03-14 15:01:00fwierzbickisetpriority: low
nosy: + fwierzbicki
messages: + msg4298
versions: + 2.5.1, - 2.5b1
2009-03-12 07:38:44zyasoftsetnosy: + zyasoft
messages: + msg4230
2009-01-30 20:01:18jfeinbergsetmessages: + msg4114
2009-01-30 20:01:03jfeinbergcreate