Issue1354

classification
Title: core language failures in interactive interpreter
Type: Severity: normal
Components: Core Versions: 25rc4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: fwierzbicki Nosy List: fwierzbicki, qny31541, undefined, zyasoft
Priority: normal Keywords:

Created on 2009-05-22.02:56:41 by undefined, last changed 2014-05-02.13:46:55 by qny31541.

Files
File name Uploaded Description Edit Remove
test.py undefined, 2009-05-22.02:56:41 test case
test.py undefined, 2009-05-22.05:24:41 test cases for nesting, multi-line strings, and lambda
Messages
msg4706 (view) Author: (undefined) Date: 2009-05-22.02:56:41
Jython 2.5rc2 (Release_2_5rc2:6341, May 11 2009, 17:07:28) 
[OpenJDK Client VM (Sun Microsystems Inc.)] on java1.6.0_0

double-intended/nested code read by the interpreter through manual entry
or a file read on stdin fails with a syntax error, but read as a file
specified as an argument to jython, it works fine.

$ jython test.py
True
$ jython <test.py
  File "<stdin>", line 3
    if True:
           ^
SyntaxError: mismatched input '' expecting INDENT
  File "<stdin>", line 1
    print 'True'
    ^
SyntaxError: no viable alternative at input '            '
msg4708 (view) Author: (undefined) Date: 2009-05-22.05:23:47
okay, i'm changing the bug report name because i'm beginning to realize
that the problem is bigger than previously noted.  i'm also beginning to
wonder if the problem isn't environment related (but not necessarily the
jvm because i've reproduced these bugs under openjdk6, 1.6.0_12, &
1.5.0_17).

all examples in the attached file (from the latest official python 2.5
tutorial)
- multi-line strings fail
- lambdas fail

feel free to break this up into separate bug reports, but as far as i
know it's a single bug with multiple symptoms/casualties.
msg4714 (view) Author: Jim Baker (zyasoft) Date: 2009-05-23.20:51:12
Confirmed in the console. Given this is not the sort of code normally
used in console mode - and there's a workaround of just running it
through standard evaluation - I'm setting the priority normal instead of
blocking the next RC.
msg4737 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-05-27.16:14:10
fixed in r6397.  Thanks undefined author :)
History
Date User Action Args
2014-05-02 13:46:55qny31541setnosy: + qny31541
2009-05-27 16:14:10fwierzbickisetstatus: open -> closed
resolution: fixed
messages: + msg4737
2009-05-24 00:38:01fwierzbickisetassignee: fwierzbicki
2009-05-23 20:51:13zyasoftsetpriority: normal
nosy: + fwierzbicki, zyasoft
messages: + msg4714
2009-05-22 05:24:53undefinedsetfiles: + test.py
messages: + msg4708
title: double-nested code failure in interpreter -> core language failures in interactive interpreter
2009-05-22 02:56:41undefinedcreate