Issue1356

classification
Title: [Windows] test_subprocess test_communicate_pipe_buf fails
Type: Severity: normal
Components: Library Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: otmarhumbel Nosy List: fwierzbicki, otmarhumbel, pjenvey
Priority: normal Keywords:

Created on 2009-05-26.01:21:48 by pjenvey, last changed 2010-06-01.23:33:05 by otmarhumbel.

Messages
msg4718 (view) Author: Philip Jenvey (pjenvey) Date: 2009-05-26.01:21:47
This fails on Windows because the test passes a large command line to a 
child process that seems to get cut off short. subprocess seems to be 
passing along the right args so I suspect the .bat file might be 
responsible, but I'm not sure of that yet

Shouldn't block 2.5 release
msg4774 (view) Author: Philip Jenvey (pjenvey) Date: 2009-05-31.21:38:39
This is definitely the .bat file's fault, it's due to of all things an 
asterisk. To reproduce it on the plain command line:

>dist\bin\jython -c "import sys;sys.stdout.write(\"xyz\"*1);"
  File "<string>", line 1
    import
          ^
SyntaxError: mismatched input '\n\n' expecting NAME

>python -c "import sys;sys.stdout.write(\"xyz\"*1);"
xyz
msg5253 (view) Author: Philip Jenvey (pjenvey) Date: 2009-10-21.20:07:11
The ideal solution to this is #1491
msg5624 (view) Author: Philip Jenvey (pjenvey) Date: 2010-04-04.18:05:43
#1567 probably a dupe of this, and it has a potential solution
msg5790 (view) Author: Oti Humbel (otmarhumbel) Date: 2010-06-01.23:33:03
fixed with revision 7060 - next step really is a native launcher

many thanks to Pekka Klaerck and Andreas Ebbert-Karroum for their analysis and suggestions!
History
Date User Action Args
2010-06-01 23:33:05otmarhumbelsetstatus: open -> closed
resolution: fixed
messages: + msg5790
2010-04-04 18:05:43pjenveysetmessages: + msg5624
2009-10-21 20:07:12pjenveysetmessages: + msg5253
2009-05-31 21:38:39pjenveysetassignee: otmarhumbel
messages: + msg4774
nosy: + otmarhumbel
2009-05-26 13:08:13fwierzbickisetnosy: + fwierzbicki
2009-05-26 01:21:48pjenveycreate