Issue1448

classification
Title: Ellipses prompt after enter after full statement
Type: behaviour Severity: major
Components: Core Versions: 2.5.0
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: cgroves, fwierzbicki, yhershberg
Priority: Keywords:

Created on 2009-08-26.08:15:44 by yhershberg, last changed 2013-02-19.21:11:13 by fwierzbicki.

Messages
msg5068 (view) Author: Josh hershberg (yhershberg) Date: 2009-08-26.08:15:43
After typing a full statement (function call) from within the shell the 
ellipsis prompt (...) is shown as if it is waiting for more input to 
complete the line or something. Here is a cut and paste:
Jython 2.5.0 (Release_2_5_0:6476, Jun 16 2009, 13:33:26)
[Java HotSpot(TM) Server VM (Sun Microsystems Inc.)] on java1.5.0_10
Type "help", "copyright", "credits" or "license" for more information.
>>> execfile ('jythonTest')
...
...
msg5069 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-08-26.13:07:48
Strange, I am unable to reproduce this on OSX.  If 'jythonTest' doesn't
exist I get the expected error, and if it does it gets executed on my
system (cut and pasted from your bug report) -- It's hard to imagine
that this would happen because of the contents of jythonTest, but just
to be sure: what are the contents of jythonTest and any details about
your environment (os, etc) may help.
History
Date User Action Args
2013-02-19 21:11:13fwierzbickisetstatus: open -> closed
resolution: out of date
2009-08-26 16:14:16cgrovessetnosy: + cgroves
2009-08-26 13:07:49fwierzbickisetnosy: + fwierzbicki
messages: + msg5069
2009-08-26 08:15:44yhershbergcreate