Issue1450

classification
Title: "|" was unexpected at this time.
Type: Severity: normal
Components: Core Versions: 2.5.0
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: fwierzbicki, ssteiner
Priority: Keywords:

Created on 2009-08-27.10:28:30 by ssteiner, last changed 2009-09-04.02:16:29 by fwierzbicki.

Messages
msg5074 (view) Author: simon steiner (ssteiner) Date: 2009-08-27.10:28:29
import os
os.system("(echo 1 & echo 2) | perl script.pl")
msg5075 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-08-27.16:21:19
The error message

"|" was unexpected at this time.

Is coming from your shell (looks like a windows shell to me) and not
from Jython itself.  Googling around I found a suggestion that you try
to prepend a ^ to your |.  Since this isn't a Jython bug, I'm closing it.
msg5076 (view) Author: simon steiner (ssteiner) Date: 2009-08-28.12:20:59
I dont get this error when using python or jep and using ^ doesn't help.
msg5077 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-08-28.13:37:18
Could you give me some environment details (os, etc) and what is
contained in script.pl?  If I can find a way to reproduce your error
I'll re-open it.
msg5094 (view) Author: simon steiner (ssteiner) Date: 2009-09-03.12:43:34
Contents of script.pl doesn't matter, i only get this on Windows not on
Linux.
msg5096 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2009-09-04.02:16:28
Maybe you can provide a test case that will run on Linux but not on
Windows then?  Otherwise I won't be able to reproduce the bug.
History
Date User Action Args
2009-09-04 02:16:29fwierzbickisetmessages: + msg5096
2009-09-03 12:43:34ssteinersetmessages: + msg5094
2009-08-28 13:37:19fwierzbickisetmessages: + msg5077
2009-08-28 12:20:59ssteinersetmessages: + msg5076
2009-08-27 16:21:19fwierzbickisetstatus: open -> closed
resolution: invalid
messages: + msg5075
nosy: + fwierzbicki
2009-08-27 10:28:30ssteinercreate