Issue1476

classification
Title: cPickle.load(...) gives a NullPointerException in Unpickler.load() when key is INST!
Type: crash Severity: urgent
Components: Any Versions: 2.5.0
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: Humbie, pjenvey
Priority: Keywords:

Created on 2009-09-28.12:07:23 by Humbie, last changed 2010-04-10.16:10:02 by pjenvey.

Files
File name Uploaded Description Edit Remove
database.db Humbie, 2009-09-28.12:07:20
Messages
msg5196 (view) Author: Jan Van humbeek (Humbie) Date: 2009-09-28.12:07:20
When trying to UnPickle the attached database.db file, I get a 
NullPointerException in UnPickler's load() method when the found key 
equals INST.
This points to the function load_inst() which in turn points to 
find_class(...,...) where it appears that "dict" is null.
I'm not an experienced Python programmer, I just use the cPickle 
functionality to read from a Python-generated db-file. I have access to 
the code which generates the file, but as I'm not a Python programmer, I 
hardly understand it. Hope that anyone can resolve this issue I'm 
having.
msg5212 (view) Author: Philip Jenvey (pjenvey) Date: 2009-10-01.01:39:14
We can't reproduce it with just the database.db file, it fails while 
trying to lookup the associated classes:

>>> load(open('database.db'))
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named myo_achievement
msg5651 (view) Author: Philip Jenvey (pjenvey) Date: 2010-04-10.16:10:01
There's been no response for a while, so closing this issue out. Please reopen the bug if you can provide a test case we can fully reproduce
History
Date User Action Args
2010-04-10 16:10:02pjenveysetstatus: open -> closed
resolution: out of date
messages: + msg5651
2009-10-01 01:39:14pjenveysetnosy: + pjenvey
messages: + msg5212
2009-09-28 12:07:23Humbiecreate