Issue1506

classification
Title: Jython applies PEP263 pattern for determining source-code encoding on noncomments
Type: behaviour Severity: normal
Components: Core Versions: 2.5.1
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: r_walter, zyasoft
Priority: Keywords:

Created on 2009-11-20.15:31:09 by r_walter, last changed 2010-07-20.03:51:04 by zyasoft.

Messages
msg5316 (view) Author: Roland Walter (r_walter) Date: 2009-11-20.15:31:08
Enter the command line interpreter and try to asign a string value that
contains the following: coding: 8bit. 

You get the error message that the encoding 8bit is unknown. This does
not happen in CPython.

This is it what you see on Jython:

Jython 2.5.1 (Release_2_5_1:6813, Sep 26 2009, 13:47:54)
[Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on java1.6.0_17
Type "help", "copyright", "credits" or license for more information.
>>> line = '"Content-Transfer-Encoding: 8bit"'
  File "<stdin>", line 1
SyntaxError: Unknown encoding: 8bit
msg5900 (view) Author: Roland Walter (r_walter) Date: 2010-07-15.15:37:58
Due to this bug the Wiki moin (http://moinmo.in) will not work with jython.
msg5902 (view) Author: Jim Baker (zyasoft) Date: 2010-07-16.23:17:39
Wow, that's an unexpected bug, but it makes perfect sense. Looks like the problem is that we don't pass enough info down from the partial parse (in Py#compile_command_flags) to get the right sort of reader. So in particular, we should not be using ExpectedEncodingBufferedReader here.
msg5908 (view) Author: Jim Baker (zyasoft) Date: 2010-07-20.03:51:03
Fixed by r7079
History
Date User Action Args
2010-07-20 03:51:04zyasoftsetstatus: open -> closed
messages: + msg5908
title: Jython applies pattern for determining source-code encoding even on simple evaluation of strings -> Jython applies PEP263 pattern for determining source-code encoding on noncomments
2010-07-16 23:17:39zyasoftsetnosy: + zyasoft
messages: + msg5902
2010-07-15 15:37:58r_waltersetmessages: + msg5900
2009-11-20 15:31:09r_waltercreate