Issue1526

classification
Title: set is not serializable
Type: behaviour Severity: normal
Components: Core Versions: 2.5.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: colinhevans, pjenvey
Priority: Keywords:

Created on 2009-12-18.00:19:13 by colinhevans, last changed 2009-12-19.00:34:44 by pjenvey.

Messages
msg5386 (view) Author: Colin Evans (colinhevans) Date: 2009-12-18.00:22:22
set() is not serializable using Java serialization because set() uses 
org.python.core.util.ConcurrentHashSet which marks membership in the set 
using ConcurrentHashSet.PRESENT, and ConcurrentHashSet.PRESENT doesn't 
implement serializable.

Solution is to use something serializable, i.e. the String "present".
msg5388 (view) Author: Philip Jenvey (pjenvey) Date: 2009-12-19.00:34:44
dupe of #1511
History
Date User Action Args
2009-12-19 00:34:44pjenveysetstatus: open -> closed
resolution: duplicate
messages: + msg5388
nosy: + pjenvey
versions: + 2.5.1, - Jython 2.1
2009-12-18 00:22:33colinhevanssettitle: set are not serializable -> set is not serializable
2009-12-18 00:22:23colinhevanssetmessages: + msg5386
title: set() is not serializable -> set are not serializable
2009-12-18 00:19:13colinhevanscreate