Issue1533624

classification
Title: NPE thrown building traceback for a call in invokeAndWait
Type: Severity: normal
Components: None Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: cgroves, kzuberi
Priority: normal Keywords:

Created on 2006-08-03.04:00:33 by cgroves, last changed 2006-08-05.20:21:09 by cgroves.

Messages
msg1188 (view) Author: Charlie Groves (cgroves) Date: 2006-08-03.04:00:33
Anand Chitipothu sent this into jython dev and user. 
http://article.gmane.org/gmane.comp.lang.jython.user/4726

The exception occurs when jython code calls
SwingUtilities.invokeAndWait(or anything that puts code
on a thread and waits for its result) and the code run
on the event dispatch thread throws an exception.  When
a jython call descends into more jython code running on
another thread, the frame right after the threads
separate doesn't have f_back set to the previous frame.
 Since PyTableCode uses f_back to build tracebacks this
throws an NPE.
msg1189 (view) Author: Charlie Groves (cgroves) Date: 2006-08-03.04:07:23
Logged In: YES 
user_id=1174327

Fixed in r2870.
msg1190 (view) Author: Khalid Zuberi (kzuberi) Date: 2006-08-03.20:54:35
Logged In: YES 
user_id=18288


Would it make sense to add a bugtest for this to guard
against future regressions?

- kz
msg1191 (view) Author: Charlie Groves (cgroves) Date: 2006-08-05.20:21:09
Logged In: YES 
user_id=1174327

Sounds like a good idea to me.  I just added a simplified
version of Anand's initial code as test389.
History
Date User Action Args
2006-08-03 04:00:33cgrovescreate