Issue1538

classification
Title: Install indicates success. Program does not start
Type: behaviour Severity: normal
Components: Installer Versions: 2.5.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: TimVukman, otmarhumbel
Priority: Keywords:

Created on 2010-01-12.14:23:13 by TimVukman, last changed 2010-01-13.18:32:27 by otmarhumbel.

Messages
msg5428 (view) Author: Tim Vukman (TimVukman) Date: 2010-01-12.14:23:12
I have installed version 2.5.1 using the "standard" option.

I double click the batch file.  A DOS box opens and quickly closes.

The program does not run.  I get no error message.  Task manager does not show Jython running.

Same issue when I try to load a .py file from the examples.

Environment is Windows7
msg5433 (view) Author: Oti Humbel (otmarhumbel) Date: 2010-01-13.17:21:47
I was able to grab a VMware image of Windows 7 RC.
Installed Java SE 6 (Update 17).
Installed jython.
Opened a console window (cmd.exe)
cd to the jython 2.5.1 installation dir, and typed 'jython'
This gave me:
C:\Users\bagside\stuff\jython\jython-2.5.1>jython
*sys-package-mgr*: processing new jar, 'C:\Users\bagside\stuff\jython\jython-2.5.1\jython.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\resources.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\rt.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\jsse.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\jce.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\charsets.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\dnsns.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\localedata.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\sunjce_provider.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\sunmscapi.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\sunpkcs11.jar'
Jython 2.5.1 (Release_2_5_1:6813, Sep 26 2009, 13:47:54)
[Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on java1.6.0_17
Type "help", "copyright", "credits" or "license" for more information.
>>>

When I double click on the jython.bat file, I get:
'\\BAGSIDE-PC\Users\bagside\stuff\jython\jython-2.5.1'
CMD.EXE was started with the above path as the current directory.
UNC paths are not supported.  Defaulting to Windows directory.
Jython 2.5.1 (Release_2_5_1:6813, Sep 26 2009, 13:47:54)
[Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on java1.6.0_17
Type "help", "copyright", "credits" or "license" for more information.
>>>

There are 2 
  @echo off 
lines at the beginning of jython.bat
Please comment them out as follows:
  REM @echo off
and then try to start jython.bat from a console window (cmd.exe).
The output could be helpful.
msg5434 (view) Author: Oti Humbel (otmarhumbel) Date: 2010-01-13.18:32:26
This is a duplicate of http://bugs.jython.org/issue1330
Tim provided a console output, saying at the end:

C:\jython2.5.1standard>if not defined _ARGS goto 
argsDone\Java\jre6\lib\ext\QTJava.zip was unexpected at this time.
C:\jython2.5.1standard>    set 
CLASSPATH=C:\jython2.5.1standard\jython.jar;.;C:\Program Files 
(x86)\Java\jre6\lib\ext\QTJava.zip
C:\jython2.5.1standard>
History
Date User Action Args
2010-01-13 18:32:27otmarhumbelsetstatus: open -> closed
resolution: duplicate
messages: + msg5434
2010-01-13 17:21:47otmarhumbelsetnosy: + otmarhumbel
messages: + msg5433
2010-01-12 14:23:13TimVukmancreate