Issue1603

classification
Title: Running Jython using Windows Vista Home Premium
Type: behaviour Severity: critical
Components: Core Versions: 2.5.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: otmarhumbel, pepper2, zyasoft
Priority: Keywords:

Created on 2010-04-27.02:48:00 by pepper2, last changed 2010-04-30.16:30:35 by otmarhumbel.

Files
File name Uploaded Description Edit Remove
zztest-jython.bat pepper2, 2010-04-27.02:47:59 jython.bat file (windows bat file)
Messages
msg5751 (view) Author: Sheri Pepper (pepper2) Date: 2010-04-27.02:47:59
- Downloaded Jython with a Windows Vista Home Premium OS- 64-bit. 
- Jython.bat file opens up a command window, and then closes (console blinks on/off)
- I made a copy of the bat file and put in displays ((echo's)) to see where it was dying -- (please see attached zztest-jython.bat)
- In it, I REM (remarked) the pattern it went through
      ..it went up to --> rem - hello88a  (in :argsDone)
          rem - ..and then the screen quits...
msg5755 (view) Author: Jim Baker (zyasoft) Date: 2010-04-27.23:44:07
We have known problems in argument parsing. We expect this bug to be resolved by #1491 (using a native executable instead of a batch file). Keeping this open since they're all subtly different.
msg5756 (view) Author: Oti Humbel (otmarhumbel) Date: 2010-04-30.16:30:34
This is a duplicate of #1548 (64 bit), and was fixed in revision 6965

I'll try to fix argument processing in .bat as far as possible, and will then go for a native launcher.
History
Date User Action Args
2010-04-30 16:30:35otmarhumbelsetstatus: open -> closed
resolution: accepted -> duplicate
messages: + msg5756
nosy: + otmarhumbel
2010-04-27 23:44:07zyasoftsetresolution: accepted
messages: + msg5755
nosy: + zyasoft
2010-04-27 02:48:00pepper2create