Issue1650

classification
Title: Current Jython docs refer to Python 2.6 functionality
Type: behaviour Severity: normal
Components: Core, Library Versions: Jython 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: juneau001 Nosy List: esatterwhite, fwierzbicki, juneau001, zyasoft
Priority: high Keywords:

Created on 2010-08-27.03:18:49 by esatterwhite, last changed 2014-05-10.05:44:53 by zyasoft.

Messages
msg6021 (view) Author: Eric (esatterwhite) Date: 2010-08-27.03:18:49
the data structure deque from the collections module is documented as allowing a maxlen argument. 

code:
from collections import deque
d = deque([], 5)

results in:
deque() takes at most 1 arguments (2 given)

deque([], maxlen=5)
deque() does not take keyword arguments.

Either way, there is no way to specify a maximum length on the deque object
msg6022 (view) Author: Jim Baker (zyasoft) Date: 2010-08-27.03:53:33
maxlen becomes available as of Python 2.6; Jython 2.5.x only implements 2.5 functionality. 

So this is a documentation issue. (For a number of reasons, we backported the 2.6 docs, but haven't completed revising them to 2.5.)

2.5.2 final must have this and related issues resolved.
msg6075 (view) Author: Jim Baker (zyasoft) Date: 2010-09-20.18:56:26
Generalized title. This will ideally be resolved by a doc sprint we are planning sometime in October.
msg6114 (view) Author: Juneau001 (juneau001) Date: 2010-10-01.14:26:43
Similar bug has been noted in issue #1590.  Plan to address these issues with a community sprint for documentation cleanup.
msg8366 (view) Author: Jim Baker (zyasoft) Date: 2014-05-10.05:44:53
Duplicate of #1590
History
Date User Action Args
2014-05-10 05:44:53zyasoftsetstatus: open -> closed
resolution: accepted -> duplicate
messages: + msg8366
2013-02-19 18:17:55fwierzbickisetnosy: + fwierzbicki
versions: + Jython 2.5, - 2.5.2b1
2010-10-01 14:26:44juneau001setmessages: + msg6114
2010-09-20 18:56:27zyasoftsetmessages: + msg6075
title: Jython docs do not accurately describe the deque type -> Current Jython docs refer to Python 2.6 functionality
2010-08-27 11:39:01juneau001setassignee: juneau001
2010-08-27 03:53:34zyasoftsetpriority: high
nosy: + zyasoft, juneau001
resolution: accepted
messages: + msg6022
title: deque only does not accept maxlen -> Jython docs do not accurately describe the deque type
2010-08-27 03:18:50esatterwhitecreate