Issue1671213

classification
Title: pickle/cPickle of Sets bug
Type: Severity: normal
Components: Library Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: pjenvey, rabidechidna, yole
Priority: normal Keywords:

Created on 2007-02-28.20:46:06 by rabidechidna, last changed 2008-04-06.00:57:41 by pjenvey.

Messages
msg1515 (view) Author: D Morley (rabidechidna) Date: 2007-02-28.20:46:06
Pickling and unpickling of sets results in an empty set.
The code:

import pickle, sets
myset = sets.Set([0])
print myset, pickle.loads(pickle.dumps(myset, -1))

prints out:

Set([0]) Set([])

Same for cPickle and for ImmutableSet.
msg1516 (view) Author: Dmitry Jemerov (yole) Date: 2007-08-11.10:33:18
Regular pickle of sets works correctly in the 2.3 branch as of today. Patch to fix cPickle is posted at http://sourceforge.net/tracker/index.php?func=detail&aid=1772172&group_id=12867&atid=312867
msg3119 (view) Author: Philip Jenvey (pjenvey) Date: 2008-04-06.00:57:40
I can't find any record of the patch Dmitry references, but it must have 
already been incorporated because I can't reproduce this with pickle or 
cPickle on both 2.2.1 and trunk. closing out
History
Date User Action Args
2008-04-06 00:57:41pjenveysetstatus: open -> closed
resolution: fixed
messages: + msg3119
nosy: + pjenvey
2007-02-28 20:46:06rabidechidnacreate