Issue1717

classification
Title: jython 2.5.2 saxutils: driver drv_javasax.py fails to parse attribute with 2-letters name
Type: behaviour Severity: critical
Components: Library Versions: 2.5.2b1, 2.5.2rc
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, dingo, sruchet, w_hunger
Priority: Keywords:

Created on 2011-03-15.09:50:01 by sruchet, last changed 2012-04-01.18:17:13 by amak.

Files
File name Uploaded Description Edit Remove
bug_jython.zip sruchet, 2011-03-15.09:50:00 zip file containing example and fix
Messages
msg6436 (view) Author: Stephane Ruchet (sruchet) Date: 2011-03-15.09:50:00
in version 2.5.2 (Release_2_5_2:7206, Mar 2 2011, 23:12:06)

Parsing xml data containing an attribute with 2-letters length works with python 2.5.2 but fails with jython.
It comes from class AttributesImpl in driver drv_javasax.py, that uses NameSpace. It should not use NameSpace, as it is used by the subclass AttributesNSImpl.

I attached a zip file containing an example, the Original python module and the fixed one.
msg6470 (view) Author: Werner Hunger (w_hunger) Date: 2011-04-06.09:47:09
I stumbled across the same problem. I do not understand it completely, but i think the real cause is in _fixTuple():

>diff drv_javasax.py.ORIG drv_javasax.py
241c241
<     if len(nsTuple) == 2:
---
>     if isinstance(nsTuple, tuple) and len(nsTuple) == 2:
msg6473 (view) Author: jeff quast (dingo) Date: 2011-04-07.17:40:51
Same problem. This is not present in version 2.5b1
msg7014 (view) Author: Alan Kennedy (amak) Date: 2012-04-01.18:16:38
Closing this issue as a duplicate of #1768 which was fixed here

2.5:  http://hg.python.org/jython/rev/936bd1b132eb
head: http://hg.python.org/jython/rev/179cb4437158
History
Date User Action Args
2012-04-01 18:17:13amaksetresolution: fixed -> duplicate
2012-04-01 18:16:38amaksetstatus: open -> closed
assignee: amak
resolution: fixed
messages: + msg7014
nosy: + amak
2011-04-07 17:40:51dingosetnosy: + dingo
messages: + msg6473
2011-04-06 09:47:10w_hungersetnosy: + w_hunger
messages: + msg6470
2011-03-15 09:50:01sruchetcreate