Issue1746106

classification
Title: ^C quits Jython commandline
Type: Severity: normal
Components: Core Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: a_o_m, pjenvey
Priority: low Keywords:

Created on 2007-07-01.16:49:51 by a_o_m, last changed 2009-06-22.02:14:29 by pjenvey.

Messages
msg1696 (view) Author: Alexander (a_o_m) Date: 2007-07-01.16:49:51
"CTRL+c" quits Jython. This differs from CPython were it's ignored and only "KeyboardInterrupt" is logged to stout. One would expect that only "CTRL+d" quits Jythona as in CPython.

In conjunction with jline-0.9.91.jar - after a "CTRL+c" - Jython commandline becomes non-responsive and JVM eats all CPU cycles.
msg4847 (view) Author: Philip Jenvey (pjenvey) Date: 2009-06-22.02:14:29
#1270 is a dupe of this but I'm closing this one out as the other has more 
chatter
History
Date User Action Args
2009-06-22 02:14:29pjenveysetstatus: open -> closed
resolution: duplicate
messages: + msg4847
nosy: + pjenvey
2009-03-03 18:21:55fwierzbickisetpriority: normal -> low
2007-07-01 16:49:51a_o_mcreate