Issue1752

classification
Title: Invalid or Corrupt Jarfile jython_installer-2.5.2.jar
Type: Severity: critical
Components: Installer Versions: 2.5.2b1, 2.5.2rc
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: amak, hyao, irmen, kkatona
Priority: Keywords:

Created on 2011-05-31.18:30:12 by kkatona, last changed 2012-03-19.18:58:01 by amak.

Files
File name Uploaded Description Edit Remove
jython_fail.png kkatona, 2011-05-31.18:30:12
Messages
msg6533 (view) Author: kkatona (kkatona) Date: 2011-05-31.18:30:12
The installer for Jython 2.5.2 errors upon opening via click or via Command prompt. Tried to run in Windows 7 Enterprise (x64) and Win 2003 Server with same results.
msg6534 (view) Author: H Yao (hyao) Date: 2011-05-31.20:48:31
Maybe you could download the installer again?

Does the md5 match as shown on http://www.jython.org/downloads.html?
msg6535 (view) Author: kkatona (kkatona) Date: 2011-06-01.12:32:40
I have downloaded the installer about 10 times. I also tried using the 2.5.1 installer with the same results. I checked the MD5 of three separate 2.5.2 installer downloads and they were all different and did not match the given MD5 on the downloads page.
msg6536 (view) Author: H Yao (hyao) Date: 2011-06-01.13:09:07
just download Jython 2.5.2 on http://www.jython.org/downloads.html and make sure the md5 match. didn't have a problem here.
msg6673 (view) Author: Irmen de Jong (irmen) Date: 2011-10-12.22:32:42
no problems at all on my machine (window 7 64 bit, jdk 1.6) the laucher starts correctly when doubleclicking the jar.
msg6834 (view) Author: Alan Kennedy (amak) Date: 2012-03-19.18:58:01
"""
I have downloaded the installer about 10 times. I also tried using the 2.5.1 installer with the same results. I checked the MD5 of three separate 2.5.2 installer downloads and they were all different and did not match the given MD5 on the downloads page.
"""

Other have been unable to reproduce your issue. When they download the same file form the same source, the file is intact and matches the published MD5.

If your download does not match the published MD5, then there is some form  of corruption happening after exiting the download server, e.g. content transformation by a proxy, file system corruption, etc.

Since no has been able to reproduce, we have no choice but to close this report.
History
Date User Action Args
2012-03-19 18:58:01amaksetstatus: open -> closed
resolution: rejected
messages: + msg6834
nosy: + amak
2011-10-12 22:32:42irmensetnosy: + irmen
messages: + msg6673
2011-06-01 13:09:07hyaosetmessages: + msg6536
2011-06-01 12:32:41kkatonasetmessages: + msg6535
2011-05-31 20:48:31hyaosetnosy: + hyao
messages: + msg6534
2011-05-31 18:30:12kkatonacreate