Issue1801

classification
Title: MARK_LIMIT to low in ParserFacade.java
Type: crash Severity: urgent
Components: Core Versions: Jython 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: amak, fwierzbicki, philba
Priority: normal Keywords:

Created on 2011-09-28.10:50:12 by philba, last changed 2013-02-25.20:41:48 by amak.

Messages
msg6653 (view) Author: Philipp Bach (philba) Date: 2011-09-28.10:50:11
Hi there!

We would like to compile our jython scripts at runtime in pure java to gain a performance boost.
But we have to concat scripts like segments to a big script that sometimes can be bigger than 100000 characters.

I didn't find a way to concat the compiled bytecode after compiling each segment-script, so I think I need to increase the MARK_LIMIT.

Could you please make that possible?
msg6842 (view) Author: Alan Kennedy (amak) Date: 2012-03-19.19:33:31
> We would like to compile our jython scripts at runtime in pure java

You mean that you want your jython files compiled to .class files? It is not possible to compile jython to java.

> I didn't find a way to concat the compiled bytecode after compiling each segment-script

Why can't you just use the individual .class files, or put them into a jar file?
msg7752 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-25.20:34:07
No response for almost a year, I think we can close this.
msg7754 (view) Author: Alan Kennedy (amak) Date: 2013-02-25.20:41:48
Marking this as a duplicate of #1744

http://bugs.jython.org/issue1744
jython script total characters limited to 100000
History
Date User Action Args
2013-02-25 20:41:48amaksetresolution: out of date -> duplicate
messages: + msg7754
2013-02-25 20:34:07fwierzbickisetstatus: open -> closed
resolution: out of date
messages: + msg7752
2013-02-25 20:33:04fwierzbickisetpriority: normal
nosy: + fwierzbicki
versions: + Jython 2.5, - 2.5.2
2012-03-19 19:33:32amaksetnosy: + amak
messages: + msg6842
2011-09-28 10:50:12philbacreate