Issue1826

classification
Title: How to get Jython script variables to java object
Type: behaviour Severity: critical
Components: Core Versions: 2.5.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: amak, fwierzbicki, jeff.allen, neelemab
Priority: Keywords:

Created on 2011-12-13.03:20:36 by neelemab, last changed 2012-03-19.17:53:14 by amak.

Messages
msg6741 (view) Author: Neelema (neelemab) Date: 2011-12-13.03:20:35
I created a script as "svc_params['SH_CAMPAIGN_ID'] = 'CAMPAIGN_ID'"

I compiled and executed the script in java using jython compiler and interpreter.

I am trying to extract script variables in java object using PyDictionary. PyDictionary constructor does not allow assigning the reference to the internal variable Map. So i am not able to get the scripts variable values in PyDictionay(Java).Is there any way where i can get those variables to Java. The same code works for 2.2.1 but not for 2.5.2. Please find my samples files attached. Please let me know if you need more details.

Thanks in advance.
msg6765 (view) Author: Jeff Allen (jeff.allen) Date: 2012-01-28.21:41:15
Suggest we close this as superseded by 1827
msg6823 (view) Author: Alan Kennedy (amak) Date: 2012-03-19.17:53:14
Closing as a duplicate of #1827
History
Date User Action Args
2012-03-19 17:53:14amaksetstatus: open -> closed
resolution: duplicate
messages: + msg6823
nosy: + amak
2012-01-28 21:41:15jeff.allensetnosy: + jeff.allen, fwierzbicki
messages: + msg6765
2011-12-13 03:21:22neelemabsetfiles: - SurrogatePyDictionaryHash.java
2011-12-13 03:20:36neelemabcreate