Issue1847

classification
Title: JSR-223: 100K maximum Jython File Size
Type: behaviour Severity: normal
Components: Library Versions: 2.5.2rc
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: amak, jtrim
Priority: Keywords:

Created on 2012-03-09.13:27:16 by jtrim, last changed 2012-03-19.18:24:22 by amak.

Files
File name Uploaded Description Edit Remove
example.zip jtrim, 2012-03-09.13:27:16 Example of JSR223 100K Jython file size limit
Messages
msg6791 (view) Author: Jeff Trim (jtrim) Date: 2012-03-09.13:27:15
There is a 100K file size limit when a Python/Jython file is loaded and eval()'ed using JSR-223.  Any Python script loaded and executed (with a size over 100K) results in a "Mark Invalid" exception being thrown:

Exception: java.io.IOException: java.io.IOException: Mark invalid

We use Jython for test automation -- and our Jython scripts are routinely well over 100K -- in fact they are very large and can run for many days at a time.  Thank you for developing an excellent Jython framework, we have been using Jython-2.2.1 up to now -- and want to move to Jython-2.5.x.

I have attached a simple example which shows this issue.  Please let me know if I can provide any additional information.

- Jeff Trim
VeriSign
msg6831 (view) Author: Alan Kennedy (amak) Date: 2012-03-19.18:24:22
Closing as a duplicate of #1744.

Also, there is a much smaller piece of code attached to #1744 which illustrates the problem: a 7MB zip file attachment is cumbersome.
History
Date User Action Args
2012-03-19 18:24:22amaksetstatus: open -> closed
resolution: duplicate
messages: + msg6831
nosy: + amak
2012-03-09 13:27:16jtrimcreate