Issue1857

classification
Title: Test failures in test_xmlrpc.py
Type: behaviour Severity: normal
Components: Library Versions: 2.7a1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: amak Nosy List: amak, fwierzbicki
Priority: Keywords: test failure causes

Created on 2012-03-20.05:15:35 by fwierzbicki, last changed 2012-04-14.18:43:49 by amak.

Messages
msg6916 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-03-20.05:15:35
See FIXMEs in test_xmlrpc.py
msg6999 (view) Author: Alan Kennedy (amak) Date: 2012-03-31.19:42:34
This appears to be caused by us using an old version of SocketServer.py.

TCPServer gained an extra parameter, bind_and_activate.

http://bugs.python.org/issue1599845

If we update to the latest SocketServer, these issues should go away.

As an aside, why is SocketServer.py in the Lib directory of our hg repo? Is it not a cpython external?
msg7001 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-03-31.20:27:55
Maybe this will shed some light on your question :) ?

changeset:   6044:5c98d79ccc37
user:        Alan Kennedy <jython-dev@xhaus.com>
date:        Sun Oct 03 17:54:49 2010 +0000
summary:     Copying over SocketServer and test_socketserver.py from CPythonLib in order to make some jython-specific bug fixes.
msg7002 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-03-31.20:31:51
Re-reading my comment maybe that's too snarky, sorry if it was!

I know I am often taken by surprise by the actions of my past self :)
msg7005 (view) Author: Alan Kennedy (amak) Date: 2012-03-31.20:55:48
> Maybe this will shed some light on your question :) ?

Ahem, cough, eh, yes ...... my bad

pp" <-- sheepish smilie

Will fix.
msg7048 (view) Author: Alan Kennedy (amak) Date: 2012-04-11.22:55:31
I've made the requisite changes to SocketServer to get it working for 2.7.

http://hg.python.org/jython/rev/6437b9f366f8

Will re-run the xml-rpc tests.
msg7051 (view) Author: Alan Kennedy (amak) Date: 2012-04-14.15:38:46
I've re-enabled a number of tests, which were caused by use of an ephemeral port number.

http://hg.python.org/jython/rev/10816fbd95c7

Because the port number was taken *before* the actual binding of the server socket (because of deferred socket creation on jython), an attempt was made to connect a client socket to port '0', which resulted in an "Address already in use" error.

There are still some issues remaining, primarily with dangling threads.
msg7052 (view) Author: Alan Kennedy (amak) Date: 2012-04-14.17:14:42
Re-enabled more tests.

http://hg.python.org/jython/rev/5f3c1eb21b87

Non-daemon threads were causing the tests to hang.
msg7053 (view) Author: Alan Kennedy (amak) Date: 2012-04-14.17:44:11
Another test re-enabled, by emulating cpython error messages more precisely.

http://hg.python.org/jython/rev/8202bf4aedb5
msg7054 (view) Author: Alan Kennedy (amak) Date: 2012-04-14.17:51:28
Another test re-enabled, by adding test_support.captured_stdin()

http://hg.python.org/jython/rev/f9fd1f69ed01

Only 1 failing test left now :-)
msg7056 (view) Author: Alan Kennedy (amak) Date: 2012-04-14.18:43:49
The last remaining failing test is caused by a problem with 

sys.setdefaultencoding

As described in

http://bugs.jython.org/issue1875

Resolving this issue in favor of that issue.
History
Date User Action Args
2012-04-14 18:43:49amaksetstatus: open -> closed
resolution: fixed
messages: + msg7056
2012-04-14 17:51:29amaksetmessages: + msg7054
2012-04-14 17:44:11amaksetmessages: + msg7053
2012-04-14 17:14:42amaksetmessages: + msg7052
2012-04-14 15:38:47amaksetmessages: + msg7051
2012-04-11 22:55:31amaksetmessages: + msg7048
2012-03-31 20:55:48amaksetassignee: amak
messages: + msg7005
2012-03-31 20:31:51fwierzbickisetmessages: + msg7002
2012-03-31 20:27:55fwierzbickisetmessages: + msg7001
2012-03-31 19:42:34amaksetmessages: + msg6999
2012-03-20 22:35:00amaksetnosy: + amak
2012-03-20 05:24:17fwierzbickisetmessages: - msg6917
2012-03-20 05:24:08fwierzbickisetmessages: + msg6917
2012-03-20 05:15:35fwierzbickicreate