Issue1868

classification
Title: Jython 2.5.2 creates problem with old code
Type: crash Severity: critical
Components: Core Versions: Jython 2.5
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: nobody Nosy List: amak, fwierzbicki, nobody, pradeepkumarhs, thirumalmarugan, zyasoft
Priority: high Keywords:

Created on 2012-03-30.06:00:16 by thirumalmarugan, last changed 2014-09-26.04:55:06 by zyasoft.

Files
File name Uploaded Description Edit Remove
Problem.docx thirumalmarugan, 2012-03-30.06:00:16 Problem Description
Messages
msg6986 (view) Author: Thirumal Marugan (thirumalmarugan) Date: 2012-03-30.06:00:16
Jython 2.5.2 creates problem with old code explained in the attached document.
msg6987 (view) Author: Thirumal Marugan (thirumalmarugan) Date: 2012-03-30.06:33:16
I forget to mention about java version used and OS.

root@pmo21> /opt/sun/jdk/java/bin/java -version
java version "1.6.0_26-rev"
Java(TM) SE Runtime Environment (build 1.6.0_26-rev-b22)
Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode)
root@pmo21> uname -a
SunOS pmo21 5.10 Generic_147441-01 i86pc i386 i86pc

Please let me know if you need any other details.

Regards,
Thirumal
msg6994 (view) Author: Alan Kennedy (amak) Date: 2012-03-31.16:15:50
Pasting the contents of the attached .docx file

===============================================
Problem:
After we move from Jython 2.2.1 to 2.5.2 we are facing the issue were our scripts are not fully running.

Description:
We have Jython scripts in our product and we will run this script through python interrupter via Jython.jar
Previously everything was fine.
But after we install the latest 2.5.2 jython version we are facing this issue.

Jython Code snippet:

Import statements

Declaration

os.system(<some command>);

Followed by our code


till the os.system command everything works fine.After that if we give any print statement its working.But our main code is not working.

If we remove os.system then everything is working fine.
Not sure how os.sytem is impacting our code.

If we execute our code with os.system jythonIntrepter thread ends soon without executing the full code.
No exception has been thrown from Jython.ie) python Intrupter in Jython.jar

Java Code snippet:
   org.python.util.PythonInterpreter.exec(taskScript);     This PythonInterpreter class belongs to jython.jar  
This is not throwing any exception but our scripts are failing in the middle.
1. old Jython2.2.1  --->  No Issue 
2. New Jython2.5.2 --> Issue 
 
 
Could you please help me out in finding the issue ?  
 
If you need any further information, please do let me know.
 
 
msg7007 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-04-01.00:36:54
It would be easier to diagnose this if you where able to supply a code snippet that demonstrates the problem - it will be difficult to reproduce your problem based on <followed by our code>...
msg7009 (view) Author: Thirumal Marugan (thirumalmarugan) Date: 2012-04-01.05:02:46
Thanks for your response.
the following code will be followed:

topologyplugin= TopologyPlugin(node)
topologyplugin.start()


topologyplugin is our own java class.
Which will fetch the current jython script details(like jobid, actvity id, etc) and creates object.
Due to the failure of first line its not able to invoke the start method and throws NullPointerException.

Not only this api.We have TelnetProxyPlugin and other java class. Everything has same behaviour with new version of jython.

Our code successfully executes if we have those two line above the os.system command.


I will upload the plugin implementation shortly.

Regards,
Thirumal
msg7020 (view) Author: Thirumal Marugan (thirumalmarugan) Date: 2012-04-02.09:59:21
Hi again,

Sorry for the delayed response.

code starts like this:

public TelnetProxyPlugin(String node)
    {
        super(node);
        TraceHelperExt.traceEnter(this);

        this.nodeAddress = node;
        this.connectPrompt = null;

When it reaches the super method in debugging mode python Interrupter thread get automatically terminated and main thread get the control over it.

We really don't know what exactly happening over there.
We have put the try catch block but we are not getting any exception as well.

I don't have right to upload the full file.

Please provide your valuable comment.

Regards,
Thirumal
msg7039 (view) Author: Thirumal Marugan (thirumalmarugan) Date: 2012-04-09.09:34:31
Hi,

I have tried with Jython version 2.5.0 there are also i am facing this issue.

Problem: We have set of jython code.
Which is working fine without any issues.
Once we upgrade the Jython version from 2.2.1 to 2.5.0/2.5.2 our existing code is failing.

We have the below in my code:
 os.system()

The code is working fine till this point also if we give  any print statement we are getting the print in our log.
But our program logic fails after that.

What we are doing: We are creating the object for our internal class (API).Which is not creating properly.


IF we remove os.system() from the script then our code execute without any issues.
Can someone please help me out in this.?

Thanks in advance.

Regards,
Thirumal
msg7757 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-25.21:01:23
Hi Thirumal, sorry this got dropped. If you could provide a small complete java program that will show the problem, I've assigned myself so I will be more on top of it if you can help us diagnose.
msg8132 (view) Author: Pradeepkumar H S (pradeepkumarhs) Date: 2013-09-27.11:17:19
what is a change in behavior of os.system() call in jython 2.2.1 and 2.5.2

Our scripts fail in 2.5.2 but works fine in 2.2.1, so there is some change in the behavior/internal implementation.

Code Snippet is has follows:
-----------------------------------------------------------------

class NULLpointer:

import os
import re
import string
import time
from com.ericsson.nms.umts.cnos.config.activitysupport.maaPlugin import MaaPlugin
from java.lang import *

maaPlugin = MaaPlugin(node)
maaPlugin.reportProgress(10)
maaPlugin.start()           //Its running in a "Tread"
maaPlugin.putInLog("CACLP from shell /tmp/caclp.sh "+node)
res=os.system("/tmp/caclp.sh "+node)
maaPlugin.end()
maaPlugin = MaaPlugin(node)
maaPlugin.start()  //After system call Tread is changing to main tread. 
maaPlugin.reportProgress(90)
maaPlugin.end() 

----------------------------------------------------------------------
msg8137 (view) Author: Pradeepkumar H S (pradeepkumarhs) Date: 2013-09-30.04:22:18
Please help me in this issue.

FYI.

Problem:
After we move from Jython 2.2.1 to 2.5.2 we are facing the issue were our scripts are not fully running.

Description:
We have Jython scripts in our product and we will run this script through python interrupter via Jython.jar
Previously everything was fine.
But after we install the latest 2.5.2 jython version we are facing this issue.

Jython Code snippet:

Import statements

Declaration

os.system(<some command>);

Followed by our code


till the os.system command everything works fine.After that if we give any print statement its working.But our main code is not working.

If we remove os.system then everything is working fine.
Not sure how os.sytem is impacting our code.

If we execute our code with os.system jythonIntrepter thread ends soon without executing the full code.
No exception has been thrown from Jython.ie) python Intrupter in Jython.jar

Java Code snippet:
   org.python.util.PythonInterpreter.exec(taskScript);     This PythonInterpreter class belongs to jython.jar  
This is not throwing any exception but our scripts are failing in the middle.
1.	old Jython2.2.1  --->  No Issue 
2.	New Jython2.5.2 --> Issue 
 
 
Could you please help me out in finding the issue ?  
 
If you need any further information, please do let me know.
msg8719 (view) Author: Jim Baker (zyasoft) Date: 2014-06-19.06:03:27
This issue was also raised in #2097, which we have closed out since we don't have something we can actually reproduce.
msg9034 (view) Author: Jim Baker (zyasoft) Date: 2014-09-26.04:55:06
Closing, we cannot reproduce issue.
History
Date User Action Args
2014-09-26 04:55:06zyasoftsetstatus: open -> closed
assignee: fwierzbicki -> nobody
resolution: rejected
messages: + msg9034
nosy: + nobody
2014-06-19 06:03:27zyasoftsetnosy: + zyasoft
messages: + msg8719
2013-09-30 04:22:19pradeepkumarhssetmessages: + msg8137
2013-09-27 11:17:20pradeepkumarhssetnosy: + pradeepkumarhs
messages: + msg8132
components: + Core, - Any
2013-02-25 21:01:24fwierzbickisetpriority: high
assignee: fwierzbicki
messages: + msg7757
versions: + Jython 2.5, - 2.5.2
2012-04-09 09:34:31thirumalmarugansetmessages: + msg7039
2012-04-02 09:59:21thirumalmarugansetmessages: + msg7020
2012-04-01 05:02:46thirumalmarugansetmessages: + msg7009
2012-04-01 00:36:55fwierzbickisetmessages: + msg7007
2012-04-01 00:33:55fwierzbickisetnosy: + fwierzbicki
2012-03-31 16:15:50amaksetnosy: + amak
messages: + msg6994
2012-03-30 06:33:16thirumalmarugansetmessages: + msg6987
2012-03-30 06:00:17thirumalmarugancreate