Issue1896548

classification
Title: LICENSE.txt
Type: Severity: normal
Components: Documentation Versions: 2.2.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: otmarhumbel Nosy List: cxh, otmarhumbel, pjenvey, zyasoft
Priority: normal Keywords:

Created on 2008-02-19.00:32:08 by cxh, last changed 2009-06-21.22:12:57 by pjenvey.

Messages
msg2075 (view) Author: Christopher Hylands (cxh) Date: 2008-02-19.00:32:08
In Jython 2.2.1, Windows installer version, the file
LICENSE.txt says:
--start--
The standard library is covered by the Python Software Foundation
license as well. See the Lib/LICENSE file for details.

The zxJDBC package was written by Brian Zimmer and originally licensed
under the GNU Public License.  The package is now covered by the Jython
Software License.

The command line interpreter is covered by the Apache Software
License.  See the org/apache/LICENSE file for details.
--end--

The file Lib/LICENSE does not exist, it should be
LICENSE_CPython.txt

The file org/apache/LICENSE does not exist, it should be
LICENSE_Apache.txt

msg3041 (view) Author: Oti Humbel (otmarhumbel) Date: 2008-02-20.22:46:25
That's completely true.
msg4235 (view) Author: Jim Baker (zyasoft) Date: 2009-03-12.07:57:39
Need to resolve for RC1
msg4241 (view) Author: Oti Humbel (otmarhumbel) Date: 2009-03-12.08:12:05
IMHO this is not a bug for 2.5, it is for the Release_2_2maint branch.

On trunk you find the apache license in /installer/src/org/apache, and if 
you install 2.5b3, there is a LICENSE_Apache.txt just beside our 
LICENSE.txt
msg4251 (view) Author: Jim Baker (zyasoft) Date: 2009-03-12.20:11:00
OK, moving back to normal since not 2.5.0. Oti, thanks for the
clarification.
msg4843 (view) Author: Philip Jenvey (pjenvey) Date: 2009-06-21.22:12:57
fixed in 2.5
History
Date User Action Args
2009-06-21 22:12:57pjenveysetstatus: open -> closed
resolution: fixed
messages: + msg4843
nosy: + pjenvey
2009-03-12 20:11:00zyasoftsetpriority: high -> normal
messages: + msg4251
2009-03-12 08:12:05otmarhumbelsetmessages: + msg4241
versions: + 2.2.2
2009-03-12 07:57:39zyasoftsetpriority: normal -> high
nosy: + zyasoft
messages: + msg4235
2008-02-20 22:46:26otmarhumbelsetassignee: otmarhumbel
messages: + msg3041
nosy: + otmarhumbel
2008-02-19 00:32:08cxhcreate