Issue1904

classification
Title: Port Jython to Servlet API 3.0
Type: Severity: normal
Components: Versions:
process
Status: open Resolution:
Dependencies: Superseder:
Assigned To: amak Nosy List: Arfrever, amak, fwierzbicki, zyasoft
Priority: Keywords:

Created on 2012-05-28.01:18:02 by Arfrever, last changed 2014-05-04.20:31:35 by zyasoft.

Messages
msg7161 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2012-05-28.01:18:01
I suggest to port Jython from Servlet API 2.5 to 3.0.

Servlet API 3.0 is implemented e.g. by Apache Tomcat 7.0.* (http://tomcat.apache.org/whichversion.html) and Resin 4.0.*.
msg8332 (view) Author: Jim Baker (zyasoft) Date: 2014-05-04.20:31:35
Two alternatives:

1. Update modjy

2. Use the new Fireside package, which only supports site-packages and singejar to war builds but does support Servlet API 3. The intent is to look at async support as well.
History
Date User Action Args
2014-05-04 20:31:35zyasoftsetnosy: + zyasoft
messages: + msg8332
2013-02-26 18:31:10fwierzbickisetnosy: + fwierzbicki
2012-07-17 05:06:27amaksetassignee: amak
nosy: + amak
2012-05-28 01:18:02Arfrevercreate