Issue1936

classification
Title: JBoss 7, vfs protocol in use for jarFileName in PySystemState
Type: crash Severity: normal
Components: Core Versions: 2.5.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: fwierzbicki Nosy List: amak, fwierzbicki, olivierH, otmarhumbel, tuska, vmassol
Priority: normal Keywords:

Created on 2012-06-29.12:27:50 by vmassol, last changed 2013-02-13.23:27:16 by fwierzbicki.

Files
File name Uploaded Description Edit Remove
patch1936.txt olivierH, 2012-09-27.16:06:38
Messages
msg7275 (view) Author: Vincent Massol (vmassol) Date: 2012-06-29.12:27:49
I have exactly the same problem as http://bugs.jython.org/issue1639 (see also http://xwiki.475771.n2.nabble.com/Deploying-on-JBoss-5-td5390212.html) but on JBoss AS 7 (7.1.1Final to be precise).

This time the problem is that JBoss AS7 has introduced the "vfs" protocol (and no longer "vfszip"), thus the JAR is not considered standalone and thus libs in the standalone's Lib/ directory are not taken into account...

The URL I get is from getJarFileName() is:
vfs:/Users/vmassol/Desktop/jboss-as-7.1.1.Final/standalone/deployments/xwiki.war/WEB-INF/lib/jython-standalone-2.5.2.jar/org/python/core/PySystemState.class

For details, see http://jira.xwiki.org/browse/XWIKI-7984

Thanks a lot. Would be awesome if this could make it in 2.5.3 :)
msg7278 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-06-29.14:42:43
If I'm following correctly it looks like http://bugs.jython.org/issue1639 was applied before beta2 came out - do you still see an issue on beta2? If not do you have a suggested fix?
msg7279 (view) Author: Vincent Massol (vmassol) Date: 2012-06-29.14:46:34
http://bugs.jython.org/issue1639 was in 2.5.2-rc1 (according to release notes on http://www.jython.org/latest.html).

I'm running 2.5.2 final. But this is not the same issue1639; it's similar to different. In issue 1639 the fix was to add support for the "vfszip" protocol. This issue is about also adding support for the "vfs" protocol which is in use in JBoss AS7. The fix is the same though; except checking for "vfs:" instead of "vfszip:".

Thanks
msg7281 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-06-29.16:30:32
It sounds like a pretty trivial patch, but someone would need to make sure both "vfszip" and "vfs" will work. I don't have time before 2.5.3beta to look at this myself (since it would involve setting up JBoss instances etc for testing) but I'd be very willing to review a patch that did the same. I'll add Otmar to the nosy list to see if he has input since he accepted the other patch.
msg7464 (view) Author: Olivier Heurtier (olivierH) Date: 2012-09-27.16:06:38
Here is a proposition of patch based on the implementation done for vfszip. Tested (only) with JBoss AS 7.1.1.Final on Ubuntu12.04.
msg7569 (view) Author: Vincent Massol (vmassol) Date: 2013-01-11.13:51:33
Guys, any news on this. I'd really love to have this fixed. I see olivierH added a patch. Is there a binary somewhere that I could use to test it (if that's what's holding the closing of the issue)?

Thanks a lot
msg7570 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-01-12.19:59:28
Vincent: If you can verify that olivierH's patch fixes things for you, I'll be happy to apply it.
msg7571 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-01-12.20:03:11
olivierH: Do you want me to include your full name in the commit message or should I just go with "olivierH"? The patch is small enough that I won't need to bug you about a contributor agreement - though if you wouldn't mind signing one I'll point you to the instructions.
msg7573 (view) Author: Olivier Heurtier (olivierH) Date: 2013-01-16.20:50:57
Frank: you can use my full name. I will be happy to sign a contributor 
agreement if it can make your work easier.
msg7574 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-01-16.22:23:30
Olivier Heurtier: cool, I'll plan to use your full name when Vincent verifies the fix. The instructions for signing a contributor agreement are here: http://www.python.org/psf/contrib/ - and the right form is here: http://www.python.org/psf/contrib/contrib-form/ Note that they want a bugs.python.org username and not a bugs.jython.org one ("p" instead of "j")
msg7585 (view) Author: Olivier Heurtier (olivierH) Date: 2013-01-23.20:54:33
I have signed and sent the contributor agreement today.
msg7619 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-05.15:49:26
Olivier: great! Now if we can just get Vincent to confirm that his issue is fixed. Vincent?
msg7626 (view) Author: Vincent Massol (vmassol) Date: 2013-02-06.15:09:55
Is there a binary I can get to retest?
msg7644 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-08.00:03:43
Fixed in http://hg.python.org/jython/rev/df829bcbd4f3
Thanks Olivier Heurtier!

Vincent: the fix will be in 2.5.4rc1 and 2.7beta1 which I expect to get out this week. Let me know how it goes! I won't close the bug until you confirm that it is fixed.
msg7645 (view) Author: Vincent Massol (vmassol) Date: 2013-02-08.08:22:25
Great. I'll retest when 2.5.4rc1 or 2.7beta1 are out, thanks.
msg7670 (view) Author: Vincent Massol (vmassol) Date: 2013-02-13.10:11:51
Seems like 2.5.4RC1 fixed the issue! See http://jira.xwiki.org/browse/XWIKI-8812

Thanks a lot :)
msg7677 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-13.23:00:21
Vincent: that's great! I'll go ahead and close this now. Thanks again for the patch Olivier!
History
Date User Action Args
2013-02-13 23:27:16fwierzbickisetstatus: open -> closed
resolution: fixed
2013-02-13 23:00:21fwierzbickisetmessages: + msg7677
2013-02-13 10:11:51vmassolsetmessages: + msg7670
2013-02-08 08:22:25vmassolsetmessages: + msg7645
2013-02-08 00:03:43fwierzbickisetmessages: + msg7644
2013-02-06 15:09:56vmassolsetmessages: + msg7626
2013-02-05 15:49:26fwierzbickisetmessages: + msg7619
2013-01-23 20:54:33olivierHsetmessages: + msg7585
2013-01-16 22:23:30fwierzbickisetmessages: + msg7574
2013-01-16 20:50:57olivierHsetmessages: + msg7573
2013-01-12 20:03:11fwierzbickisetpriority: normal
assignee: fwierzbicki
messages: + msg7571
2013-01-12 19:59:28fwierzbickisetmessages: + msg7570
2013-01-11 13:51:33vmassolsetmessages: + msg7569
2012-09-27 16:06:39olivierHsetfiles: + patch1936.txt
nosy: + olivierH
messages: + msg7464
2012-07-31 07:34:26tuskasetnosy: + vmassol
2012-07-31 07:28:05tuskasetnosy: + tuska, - vmassol
2012-07-17 05:04:25amaksetnosy: + amak
2012-06-29 16:30:32fwierzbickisetnosy: + otmarhumbel
messages: + msg7281
2012-06-29 14:46:34vmassolsetmessages: + msg7279
2012-06-29 14:42:43fwierzbickisetmessages: + msg7278
2012-06-29 14:38:41fwierzbickisetnosy: + fwierzbicki
2012-06-29 12:27:50vmassolcreate