Issue1939

classification
Title: jython/build.xml:629: java.lang.NoSuchMethodError: org.objectweb.asm.ClassWriter.(Lorg/objectweb/asm/ClassReader;I)
Type: behaviour Severity: normal
Components: Any Versions: Jython 2.7
process
Status: closed Resolution: invalid
Dependencies: Superseder:
Assigned To: Nosy List: fwierzbicki, sqs, wbrana
Priority: Keywords:

Created on 2012-06-30.15:41:50 by wbrana, last changed 2013-04-29.18:29:08 by fwierzbicki.

Messages
msg7291 (view) Author: (wbrana) Date: 2012-06-30.15:41:50
hg 6776:e4afcd777d1b

jython/build.xml:629: java.lang.NoSuchMethodError: org.objectweb.asm.ClassWriter.<init>(Lorg/objectweb/asm/ClassReader;I)V
	at org.python.expose.generate.ExposedTypeProcessor.<init>(ExposedTypeProcessor.java:49)
	at org.python.expose.generate.ExposeTask.expose(ExposeTask.java:49)
	at org.python.expose.generate.ExposeTask.process(ExposeTask.java:39)
	at org.python.util.GlobMatchingTask.execute(GlobMatchingTask.java:70)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:392)
	at org.apache.tools.ant.Target.performTasks(Target.java:413)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
	at org.apache.tools.ant.Main.runBuild(Main.java:811)
	at org.apache.tools.ant.Main.startAnt(Main.java:217)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
msg7292 (view) Author: (wbrana) Date: 2012-06-30.16:12:40
same with 6711:0ea5676c29a8
msg7293 (view) Author: (wbrana) Date: 2012-06-30.16:33:59
It seems asm-2 was used, instead of asm-3
msg7308 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-07-02.00:40:53
I suspect your build is somehow using the system ASM instead of the one provided with the mercurial branch...?
msg7998 (view) Author: Quinn Slack (sqs) Date: 2013-04-27.05:37:34
I am on 7106:11776cd9765b and am experiencing this same exact issue. Could somebody explain what it took to resolve this error?

I'm on 64-bit Arch Linux. Both OpenJDK 7 and Sun JDK 7 exhibit this problem. Ant 1.9.0. Ant -nouserlib -noclasspath does not help.

Thanks for any help you can provide.
msg8003 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-04-29.18:29:08
Quinn Slack: the issue is probably that you have an older version of ASM in use somehow. You could try checking your CLASSPATH, removing the ASM package on your system (not sure how that is done on Arch), and generally figuring out why an old version of ASM is in use.
History
Date User Action Args
2013-04-29 18:29:08fwierzbickisetmessages: + msg8003
2013-04-27 05:37:35sqssetnosy: + sqs
messages: + msg7998
2013-02-20 00:13:05fwierzbickisetversions: + Jython 2.7, - 2.7a2
2013-02-20 00:12:56fwierzbickisetstatus: open -> closed
resolution: invalid
2012-07-02 00:40:53fwierzbickisetnosy: + fwierzbicki
messages: + msg7308
2012-06-30 16:33:59wbranasetmessages: + msg7293
2012-06-30 16:12:40wbranasetmessages: + msg7292
2012-06-30 15:41:51wbranacreate