Issue1945

classification
Title: Opening of /dev/tty with "a" or "w" mode fails
Type: Severity: normal
Components: Versions:
process
Status: open Resolution: accepted
Dependencies: Superseder:
Assigned To: Nosy List: Arfrever, fwierzbicki, zyasoft
Priority: Keywords:

Created on 2012-07-02.00:17:25 by Arfrever, last changed 2014-06-19.16:55:04 by zyasoft.

Messages
msg7305 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2012-07-02.00:17:24
CPython:

$ LC_ALL="en_US.UTF-8" python2.7 -c 'open("/dev/tty", "a")'
$ LC_ALL="en_US.UTF-8" python2.7 -c 'open("/dev/tty", "w")'
$

Jython:

$ LC_ALL="en_US.UTF-8" jython2.7 -c 'open("/dev/tty", "a")'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
IOError: Illegal seek
$ LC_ALL="en_US.UTF-8" jython2.7 -c 'open("/dev/tty", "w")'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
IOError: Illegal seek
$
msg7849 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-02-27.18:23:57
Arfrever: Does this still fail for you?
msg7860 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2013-02-27.20:12:49
Yes.
msg7903 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2013-03-04.18:07:30
Hi Arfrever, you had been sending great patches for issues like these, then I got all legal on you and I think you stopped at that point. I hope that isn't what stopped you, but just in case: I think one of the issues is that the PSF contributor agreement was cumbersome to send. The PSF has finally launched electronic signatures which I hope will help. The form is here: http://www.python.org/psf/contrib/contrib-form/
msg8499 (view) Author: Jim Baker (zyasoft) Date: 2014-05-21.23:23:58
Not seeing any problems now with the supplied tests. Since these tests are not exactly comprehensive, I'm going to mark this pending in case Arfrever has something more to exercise.
msg8755 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2014-06-19.16:25:25
I can still reproduce this bug.
msg8758 (view) Author: Jim Baker (zyasoft) Date: 2014-06-19.16:55:04
Reopening per Arfrever's request on #jython

Apparently this is an issue only on some *nix systems; specifically I can reproduce on Ubuntu 13.10 with Jython trunk, but it works just fine on OS X 10.9
History
Date User Action Args
2014-06-19 16:55:04zyasoftsetstatus: closed -> open
resolution: works for me -> accepted
messages: + msg8758
2014-06-19 16:25:25Arfreversetmessages: + msg8755
2014-06-17 22:44:45zyasoftsetstatus: pending -> closed
2014-05-21 23:23:58zyasoftsetstatus: open -> pending
resolution: works for me
messages: + msg8499
nosy: + zyasoft
2013-03-04 18:07:30fwierzbickisetmessages: + msg7903
2013-02-27 20:12:49Arfreversetmessages: + msg7860
2013-02-27 18:23:57fwierzbickisetmessages: + msg7849
2012-07-02 00:21:14fwierzbickisetnosy: + fwierzbicki
2012-07-02 00:17:25Arfrevercreate