Issue1966

classification
Title: Float to string conversion via str() should ignore locale
Type: behaviour Severity: normal
Components: Core Versions: 2.7a2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: fwierzbicki Nosy List: Arfrever, Remram, amak, fwierzbicki
Priority: Keywords:

Created on 2012-08-28.18:55:09 by Remram, last changed 2012-10-27.23:31:04 by alex.gronholm.

Messages
msg7433 (view) Author: Remi Rampin (Remram) Date: 2012-08-28.18:59:35
While Jython 2.5.3 and all versions of Python always display "12.5" for str(12.5), Jython 2.7a2 will display "12,5" if the locale is set to use ',' as the decimal separator (regardless of what is set through the locale module).
msg7437 (view) Author: Frank Wierzbicki (fwierzbicki) Date: 2012-08-28.20:28:52
Ouch - there have been a couple of these in 2.7, all my fault. I'll have a look, thanks.
msg7442 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2012-08-28.21:14:36
Duplicate of issue #1914.

My locale uses "," as decimal separator and in yesterday snapshot of Jython 2.7 I see:
>>> str(12.5)
'12.5'
msg7445 (view) Author: Alan Kennedy (amak) Date: 2012-08-28.21:41:58
So, if this is a duplicate, should it be closed as "fixed" or "duplicate"?
History
Date User Action Args
2012-10-27 23:31:04alex.gronholmsetstatus: open -> closed
2012-10-27 23:10:43alex.gronholmsetresolution: duplicate
2012-08-28 21:41:58amaksetnosy: + amak
messages: + msg7445
2012-08-28 21:14:37Arfreversetnosy: + Arfrever
messages: + msg7442
2012-08-28 20:28:52fwierzbickisetassignee: fwierzbicki
messages: + msg7437
nosy: + fwierzbicki
2012-08-28 18:59:36Remramsetmessages: + msg7433
2012-08-28 18:55:09Remramcreate