Issue2004

classification
Title: 2.7a does not provide os.getpid on Windows
Type: Severity: major
Components: Library Versions: Jython 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: amak, behackett, fwierzbicki
Priority: Keywords:

Created on 2013-01-10.02:17:12 by behackett, last changed 2013-02-20.00:27:17 by fwierzbicki.

Messages
msg7568 (view) Author: Bernie Hackett (behackett) Date: 2013-01-10.02:17:11
This is a regression from 2.5.x:

Jython 2.5.3 (2.5:c56500f08d34+, Aug 13 2012, 14:54:35)
[Java HotSpot(TM) 64-Bit Server VM (Oracle Corporation)] on java1.7.0_10
Type "help", "copyright", "credits" or "license" for more information.
>>> import os
>>> os.getpid()
2844
>>>

Jython 2.7a2 (default:9c148a201233, May 24 2012, 15:49:00)
[Java HotSpot(TM) 64-Bit Server VM (Oracle Corporation)] on java1.7.0_10
Type "help", "copyright", "credits" or "license" for more information.
>>> import os
>>> os.getpid()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'module' object has no attribute 'getpid'
>>>

Linux and OSX are fine, os.getpid is just missing on Windows.
msg7648 (view) Author: Alan Kennedy (amak) Date: 2013-02-09.13:44:11
This works for me on Windows Server 2003 on the latest jython.

This is possibly because of the recent update of jffi jars

http://hg.python.org/jython/rev/aedad34262f9

Please can you try again with the latest jython 2.7?

If it still does not work, please provide some details of the version of Windows you are using.
msg7667 (view) Author: Bernie Hackett (behackett) Date: 2013-02-12.00:25:26
Looks good with 2.7b1 (This is Windows 7 BTW):

PS C:\jython2.7b1> .\jython.bat
Jython 2.7b1 (default:ac42d59644e9, Feb 9 2013, 15:24:52)
[Java HotSpot(TM) 64-Bit Server VM (Oracle Corporation)] on java1.7.0_10
Type "help", "copyright", "credits" or "license" for more information.
>>> import os
>>> os.getpid()
1392

This can be closed. Thanks.
History
Date User Action Args
2013-02-20 00:27:17fwierzbickisetstatus: open -> closed
nosy: + fwierzbicki
resolution: fixed
versions: + Jython 2.7, - 2.7a2
2013-02-12 00:25:26behackettsetmessages: + msg7667
2013-02-09 13:44:11amaksetnosy: + amak
messages: + msg7648
2013-01-10 02:17:12behackettcreate