Title: subprocess stdin
Type: Severity: normal
Components: Core Versions: Jython 2.7
Status: open Resolution: accepted
Dependencies: Superseder:
Assigned To: Nosy List: berdario, zyasoft
Priority: low Keywords:

Created on 2013-05-16.16:50:21 by berdario, last changed 2014-10-06.03:14:22 by zyasoft.

msg8016 (view) Author: (berdario) Date: 2013-05-16.16:50:21
jython -c "import subprocess;['cat', '-'])"

trying to input some data, it won't be used by the cat subprocess
(and you won't even be able to see what you're typing)

the same works on both cpython and pypy

I also tried to set explicitly stdin=None, but nothing changes
msg8493 (view) Author: Jim Baker (zyasoft) Date: 2014-05-21.22:59:43
Almost certainly the same issue as #2096
msg8843 (view) Author: Jim Baker (zyasoft) Date: 2014-06-28.06:28:32
There's a partial fix in, but stdin is still not available to the cat command
msg9091 (view) Author: Jim Baker (zyasoft) Date: 2014-10-06.03:14:22
I don't believe we are going to see a complete fix until we see selectable stdin support, per what JNR now can support and JRuby uses.

2.7.1 or later
Date User Action Args
2014-10-06 03:14:22zyasoftsetpriority: low
messages: + msg9091
2014-06-28 06:28:32zyasoftsetresolution: accepted
messages: + msg8843
2014-05-21 22:59:43zyasoftsetnosy: + zyasoft
messages: + msg8493
2013-05-16 16:50:21berdariocreate