Issue2054

classification
Title: ThreadStateMapping leaks
Type: Severity: normal
Components: Core Versions: Jython 2.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: zyasoft Nosy List: philipa, zyasoft
Priority: urgent Keywords:

Created on 2013-05-19.15:03:26 by philipa, last changed 2014-07-09.23:59:34 by zyasoft.

Messages
msg8022 (view) Author: Philip Aston (philipa) Date: 2013-05-19.15:03:25
The ThreadStateMappingClass stores ThreadState's in a ThreadLocal.

It provides no way to release the reference to the ThreadState, short of destroying the thread.

In particular, if you load Jython in its own classloader, then shutdown Jython (e.g. PythonInterpreter.cleanup()), the thread local pins a reference to the whole classloader.
msg8672 (view) Author: Jim Baker (zyasoft) Date: 2014-06-18.17:49:38
Duplicate of #2026
msg8814 (view) Author: Jim Baker (zyasoft) Date: 2014-06-24.18:24:23
Reviewing this again, this is a separate issue from #2026 if related in terms of what users experience.

Target beta 4; must fix for 2.7.0
msg8822 (view) Author: Jim Baker (zyasoft) Date: 2014-06-25.06:15:39
This is still very much a work in progress, but at this point I should have removed all opportunities for ClassLoader resource leaks to happen:

https://bitbucket.org/jimbaker/jython-resource-leaks
msg8833 (view) Author: Jim Baker (zyasoft) Date: 2014-06-28.03:57:10
Fixed as of http://hg.python.org/jython/rev/68912d04f6f5
History
Date User Action Args
2014-07-09 23:59:34zyasoftsetstatus: pending -> closed
2014-06-28 03:57:10zyasoftsetstatus: open -> pending
resolution: accepted -> fixed
messages: + msg8833
2014-06-25 06:15:39zyasoftsetmessages: + msg8822
2014-06-24 18:27:01zyasoftsetassignee: zyasoft
2014-06-24 18:24:23zyasoftsetpriority: urgent
resolution: duplicate -> accepted
messages: + msg8814
2014-06-18 17:49:38zyasoftsetresolution: duplicate
messages: + msg8672
nosy: + zyasoft
2013-05-19 15:04:54philipasetversions: + Jython 2.5, - Jython 2.7
2013-05-19 15:03:26philipacreate