Issue2093

classification
Title: jython CLI hangs on mismatch of input arguments to subprocess.call
Type: behaviour Severity: normal
Components: Core Versions: Jython 2.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: madhavasridhar, zyasoft
Priority: Keywords:

Created on 2013-09-29.13:51:50 by madhavasridhar, last changed 2014-05-21.20:51:45 by zyasoft.

Messages
msg8134 (view) Author: Madhava Sridhar (madhavasridhar) Date: 2013-09-29.13:51:50
I typed stdout argument to subprocess.call by mistake , PFB
>>> subprocess.check_call(['svn','help'],stdout=subprocess.PIPE)

JYTHON cli got hung.
msg8471 (view) Author: Jim Baker (zyasoft) Date: 2014-05-21.20:51:44
Tried, but I did not reproduce hanging on 2.7 (we would not fix for 2.5):

$ jython27
Jython 2.7b3+ (default:06161ebf74ee+, May 21 2014, 12:09:01)
[Java HotSpot(TM) 64-Bit Server VM (Oracle Corporation)] on java1.7.0_21
Type "help", "copyright", "credits" or "license" for more information.
>>> import subprocess
>>> subprocess.check_call(['svn','help'],stdout=subprocess.PIPE)
0
History
Date User Action Args
2014-05-21 20:51:45zyasoftsetstatus: open -> closed
resolution: works for me
messages: + msg8471
nosy: + zyasoft
2013-09-29 13:51:50madhavasridharcreate