Issue2111

classification
Title: Fix compatibility with Guava 15
Type: Severity: normal
Components: Versions: Jython 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Arfrever, fwierzbicki, zyasoft
Priority: Keywords:

Created on 2014-01-12.19:15:01 by Arfrever, last changed 2014-05-04.19:50:16 by zyasoft.

Messages
msg8221 (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) Date: 2014-01-12.19:15:01
Jython trunk fails to build with Guava 15.*.
(This problem does not occur with Guava 14.*.)

    [javac] /tmp/jython/src/org/python/modules/_collections/PyDefaultDict.java:56: error: <K,V>makeComputingMap(Function<? super K,? extends V>) is not public in MapMaker; cannot be accessed from outside package
    [javac]                 new MapMaker().makeComputingMap(
    [javac]                               ^
    [javac]   where K,V are type-variables:
    [javac]     K extends Object declared in method <K,V>makeComputingMap(Function<? super K,? extends V>)
    [javac]     V extends Object declared in method <K,V>makeComputingMap(Function<? super K,? extends V>)
    [javac] /tmp/jython/src/org/python/modules/_collections/PyDefaultDict.java:56: warning: [deprecation] <K,V>makeComputingMap(Function<? super K,? extends V>) in MapMaker has been deprecated
    [javac]                 new MapMaker().makeComputingMap(
    [javac]                               ^
    [javac]   where K,V are type-variables:
    [javac]     K extends Object declared in method <K,V>makeComputingMap(Function<? super K,? extends V>)
    [javac]     V extends Object declared in method <K,V>makeComputingMap(Function<? super K,? extends V>)
msg8321 (view) Author: Jim Baker (zyasoft) Date: 2014-05-04.19:50:12
Duplicate of #2087
History
Date User Action Args
2014-05-04 19:50:16zyasoftsetstatus: open -> closed
2014-05-04 19:50:12zyasoftsetresolution: duplicate
messages: + msg8321
2014-01-12 19:15:01Arfrevercreate