Issue2149

classification
Title: Jython standalone jar should support the site module and site-packages
Type: Severity: normal
Components: Versions: Jython 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: zyasoft Nosy List: zyasoft
Priority: high Keywords:

Created on 2014-05-17.20:22:11 by zyasoft, last changed 2014-05-22.01:06:49 by zyasoft.

Messages
msg8429 (view) Author: Jim Baker (zyasoft) Date: 2014-05-17.20:22:11
Standalone mode in Jython is restricted to only classes bundled in Lib/. For purposes of working with Clamp, it would be ideal if pth files (as supported by site.py) was supported, along with Lib/site-packages

The first part of this solution can modify site.addpackage such that it attempts to open, then process, pth files if available by using ClassLoader.getResourceAsStream. Such FileInputStreams can be given to the open function; the class loader should likely be Thread.currentThread().getContextClassLoader()
msg8430 (view) Author: Jim Baker (zyasoft) Date: 2014-05-17.20:22:37
Target beta 4
msg8531 (view) Author: Jim Baker (zyasoft) Date: 2014-05-22.01:06:49
Duplicate of #2143
History
Date User Action Args
2014-05-22 01:06:49zyasoftsetstatus: open -> closed
resolution: accepted -> duplicate
messages: + msg8531
2014-05-17 20:22:38zyasoftsetpriority: high
assignee: zyasoft
resolution: accepted
messages: + msg8430
2014-05-17 20:22:11zyasoftcreate