Issue2156

classification
Title: import decimal hangs
Type: Severity: major
Components: Any Versions: Jython 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: alexykot, zyasoft
Priority: Keywords:

Created on 2014-05-28.19:33:00 by alexykot, last changed 2014-06-25.16:04:26 by zyasoft.

Messages
msg8583 (view) Author: Alex (alexykot) Date: 2014-05-28.19:33:00
consider test jython script

----- SCRIPT START -----
#!/opt/jython/jython
print 'script started'
import decimal
print 'script done'
----- SCRIPT END -----

in jython2.7b1 it works fine, in jython2.7b2 it hangs forever on `import decimal`, with java process eating all CPU.

Environment:
Debian wheezy on ARMv7 CPU, Jython 2.7b2, OpenJDK java1.7.0_25.

PS: In fact I have a little more advanced application than that script, but when I tried updating from jython2.7b1 to jython2.7b2 - found this issue.
msg8681 (view) Author: Jim Baker (zyasoft) Date: 2014-06-18.19:34:57
I'm not able to reproduce this behavior on trunk - it works just fine and we do test decimal as part of our regrtest, so that should have been true of beta 2 as well.
History
Date User Action Args
2014-06-25 16:04:26zyasoftsetstatus: pending -> closed
2014-06-18 19:34:57zyasoftsetstatus: open -> pending
resolution: works for me
messages: + msg8681
nosy: + zyasoft
2014-05-28 19:33:00alexykotcreate