Title: test_java_integration hangs during regrtest
Type: Severity: normal
Components: Core Versions: Jython 2.7
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: jeff.allen, stefan.richthofer, zyasoft
Priority: Keywords:

Created on 2016-12-02.14:36:11 by stefan.richthofer, last changed 2017-04-14.18:49:20 by stefan.richthofer.

File name Uploaded Description Edit Remove
test_java_integration_hangs.txt stefan.richthofer, 2016-12-02.14:36:10 jstack output while test_java_integration is hanging
test_pythoninterpreter_jy-hanging.txt stefan.richthofer, 2017-01-06.15:34:16
msg10999 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2016-12-02.14:36:10
It appears that test_java_integration hangs sometimes, when launched by 'ant regrtest'.
This is likely related to, however
jstack output (attached) is different in this case. It doesn't detect a deadlock, but still test_java_integration hangs indefinitely.

However there are some similarities to jstack output of

- sun.misc.Unsafe.park is involved
- java.util.concurrent.locks.ReentrantLock$NonfairSync is involved
- Jython-Netty-Client is involved
msg11006 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-01-06.15:34:16
Meanwhile I also observed a rather similar behavior happening in test_pythoninterpreter_jy.
jstack output attached.
msg11218 (view) Author: Jeff Allen (jeff.allen) Date: 2017-03-12.20:09:44
I'm not seeing it hang, that I recall: it produces a warning:

dist\bin\jython Lib\test\
test_issue1833 (__main__.BeanPropertyTest) ... ok
test_awt_hack (__main__.BeanTest) ... ok


test_nonexistent_import_with_security (__main__.SecurityManagerTest) ... console: Failed to install 'org.python.util.JLineConsole': access denied ("java.lang.RuntimePermission" "readFileDescriptor").


The occurs in the same test function as your jstack MainThread seems to be in.
msg11308 (view) Author: Stefan Richthofer (stefan.richthofer) Date: 2017-04-14.18:49:20
This issue has most likely common cause with #2536.
#2536 was (empirically) solved as a consequence of
A detailed fix of #2536 is of low priority.
So closing this issue as duplicate of #2536.

Reopen, if this issue pops up again even after
Date User Action Args
2017-04-14 18:49:20stefan.richthofersetstatus: open -> closed
resolution: duplicate
messages: + msg11308
versions: + Jython 2.7
2017-03-12 20:09:45jeff.allensetnosy: + jeff.allen
messages: + msg11218
2017-01-06 15:34:18stefan.richthofersetfiles: + test_pythoninterpreter_jy-hanging.txt
messages: + msg11006
2016-12-02 14:37:07stefan.richthofersetnosy: + zyasoft
components: + Core
2016-12-02 14:36:11stefan.richthofercreate